PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notification Email Showing ALL Fields, not just submitted fields

  1. For some reason, when a client fills out the form here (http://register.growdance.com/group-registration/) they are getting ALL the fields in their email receipt, not just the Submitted Fields.

    There is quite a bit of conditional logic in this form so a client can register for ONE routine or up to 35. I don't want them to see all 35 unfilled fields in their email if they only registered for 2 events.

    Any ideas on how I can fix this?

    Posted 6 years ago on Saturday January 5, 2013 | Permalink
  2. Are you using {all_fields} for your admin notification currently, or something else?

    The {all_fields} merge tag will not normally include empty fields in the notification, unless you use it like this:

    {all_fields:empty}

    You can test this by leaving some option fields empty on this horrible looking form.

    http://gravity.chrishajer.com/contact-us/

    You will receive a user notification with just the information you submitted, not the empty fields.

    Posted 6 years ago on Sunday January 6, 2013 | Permalink
  3. I'm just using the {all_fields} code.

    Posted 6 years ago on Tuesday January 8, 2013 | Permalink
  4. David Peralty
    Administrator

    Are you using any custom code, or plugins that could be affecting either Gravity Forms or WordPress e-mails?

    Posted 6 years ago on Tuesday January 8, 2013 | Permalink
  5. Nate, if you like, export that form as XML and email it to me at chris@rocketgenius.com. I will install it and see if the same thing happens to me.

    Posted 6 years ago on Tuesday January 8, 2013 | Permalink