PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

notification to administrators, from email bug

  1. Hello,

    I changed the notification to admins settings:

    From Name:
    {Your Name:1}

    From Email:
    {Your Email:5}

    Reply to:
    {Your Email:5}

    but this doesn't work... when user fills out the form i always get the notification from my default email address in wordpress.

    Posted 6 years ago on Wednesday October 24, 2012 | Permalink
  2. David Peralty
    Administrator

    Are you using a SMTP plugin? Or maybe have some other potential plugin conflict that might be contributing to this?

    Can you go through these steps, please?
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 6 years ago on Wednesday October 24, 2012 | Permalink
  3. I am not using an SMTP plugin... would that be the issue?

    Posted 6 years ago on Wednesday October 24, 2012 | Permalink
  4. The From email header can be modified by your host or SMTP host, which is why it can appear to come from the wrong email address. If your host is rewriting the header, there is not a lot you can do other than using a different host to deliver your mail.

    I recommend installing and configuring one of these SMTP plugins.

    http://wordpress.org/extend/plugins/wp-mail-smtp/
    http://wordpress.org/extend/plugins/configure-smtp/
    http://wordpress.org/extend/plugins/cimy-swift-smtp/

    Once you have configured one of those and have successfully sent the test message, please see if your notification emails arrive from the correct address.

    Posted 6 years ago on Thursday October 25, 2012 | Permalink
  5. I did try to use gmail SMTP but it's blocked by my host...

    The only server i am allowed to use using the SMTP plugin is:

    mrvnet.kundenserver.de on port 25.

    I think you are right, the host is rewriting the header - are there no workarounds?

    Posted 6 years ago on Thursday October 25, 2012 | Permalink
  6. this is the answer i got from y hosting provider... i am at a dead-end.

    We sincerely apologize for the inconvenience. We would like to inform you that using our SMTP servers to send emails in Websites is not advisable already. Since the SMTP servers such as the SMTP server that you are using right now is not reliable. The server sometimes work, and sometimes it does not. Instead of using SMTP based plug-ins, we advise you to use form plug-ins that is using sendmail.

    is gravity forms using sendmail ?

    Posted 6 years ago on Saturday October 27, 2012 | Permalink
  7. cardscomputers
    Member

    Hey guys, I'm also having the same problem however I'm running my own dedicated server. What is the ideal email configuration for gravity forms so that these notifications use the From Name that the user types in rather than the WP Site Title?

    The from: email address seems to be correct. It's using the user-defined email address. Just not the From Name.

    [EDIT] I have since used the WP Mail SMTP plugin and configured all WP emails to be sent via SMTP rather than the mail() function. The test runs fine, but my Gravity Forms notifications still show the "From name" as the WP Site Title and the not the name of the person who filled out the contact form.

    Posted 6 years ago on Thursday November 8, 2012 | Permalink
  8. David Peralty
    Administrator

    Andy - Gravity Forms is using wp-mail.php (or WordPress' Sendmail script), but you were already having issues with that. Your host should support third party SMTP servers.

    cardscomputers - You have the from name listed in the Notifications but it is being re-written to show your site name? Are you sure it isn't a plugin conflict?

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 6 years ago on Thursday November 8, 2012 | Permalink
  9. cardscomputers
    Member

    Hey there Dave, thanks for the reply. As it turns out, it's a conflict with BuddyPress. Unfortunately it's a critical component on the site I'm working on. The moment I disable it, the From Name is showing up as the user that filled out the form.

    Very weird. It doesn't appear that BP has any email settings either. I've tried a couple plugins that change the From Name and From Email address, however it's only a static setting and doesn't solve the problem.

    Posted 6 years ago on Thursday November 8, 2012 | Permalink

This topic has been resolved and has been closed to new replies.