PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notifications

  1. Hi guys,

    My client is having an issue with receiving notifications, they work sometimes but then seems to stop for extended periods of time. I have updated to latest version etc, but she is still having the issue. The form is located here: http://www.marissameyer.com/connect/

    I am stumped as to what the issue could be and wondered if it is something you have come across in the past.

    Just email me if you would like WP login details / FTP etc...

    Cheers
    Paul

    Posted 8 years ago on Thursday September 13, 2012 | Permalink
  2. David Peralty

    Hi Paul, there are various people that have had issues with notifications. Gravity Forms sends the information to WordPress' built-in sendmail system. You'll want to probably install and configure a WordPress SMTP plugin so that it is more stable/consistent.

    Posted 8 years ago on Thursday September 13, 2012 | Permalink
  3. Can you be more specific as to what SMTP plugin we need to d/l and install? I just got a frantic call from a client when she realized she was no longer receiving notifications. This is really problematic as when I set these things up and they work I expect them to keep working.

    Posted 8 years ago on Friday September 14, 2012 | Permalink
  4. There are several but we have had good luck with both of these:

    http://wordpress.org/extend/plugins/wp-mail-smtp/
    http://wordpress.org/extend/plugins/configure-smtp/

    (I prefer the first personally)

    Posted 8 years ago on Friday September 14, 2012 | Permalink
  5. It's not working. I don't say this lightly...this is the first time I've been seriously disappointed with this plugin. Notifications are at the core of Gravity Forms. We shouldn't need another plugin to get that to work. It worked before. Why are so many of us all the sudden not receiving notifications? I'm palpably upset because my day is compromised because of this inconsistency. These solutions are not working. I've had to simply pull the form.

    Posted 8 years ago on Friday September 14, 2012 | Permalink
  6. This is not the fault of Gravity Forms. Gravity Forms hands off email notifications to the wp_mail() function of WordPress. WordPress then calls the underlying mail delivery mechanism for your server, and every server is different. When you use an SMTP plugin, you eliminate all variability with host configuration and whatever mail transport they use.

    If you install and properly configure an SMTP plugin, all mail from your WordPress site will be sent via that SMTP server, which is far more reliable than the web host's sendmail or other built in mail function.

    There can also be issues with email receipt based on the recipient's email address and the address the email from your server appears to come from.

    If you'd like help configuring the SMTP plugin to get more reliable delivery, we'll be happy to help.

    If you'd like to read more about the problem, Joost de Valk has written something up which describes the problem and offers some solutions for making email delivery more reliable http://yoast.com/email-reliability/

    Posted 8 years ago on Friday September 14, 2012 | Permalink
  7. jasonpaul: I have been having the same problem for 2 weeks. I installed the WP Mail SMTP as the administrator suggested and set it up to use my Gmail account, per these instructions: http://wordpress.org/extend/plugins/wp-mail-smtp/faq/. It worked great! Hope it continues. I have been using Gravity Forms for over 2 years and this is the first time I have had this problem. But, the fix worked. Hope it does for you too.

    Posted 8 years ago on Sunday September 16, 2012 | Permalink
  8. Thought I'd chirp in here because I've been dealing with the same problem.
    Notifications not working and all entries going to spam.
    Check Askimet. Even if the GF option is set to off.
    My client's Askimet was configured properly but it was not connecting to the Askimet servers for some reason, dark green warning. He said it had been like that for a while.
    All I did was click the Update Options button, Askimet servers were pinged successfully and wasam, everything worked.

    Posted 8 years ago on Tuesday October 16, 2012 | Permalink
  9. That's good information. Thank you for that Chip.

    Posted 8 years ago on Tuesday October 16, 2012 | Permalink
  10. I have the same problem and this fix WORKED! Makes me wonder if GF could include something similar in their next version.... It seemed to me that bypassing the WP Mailer might resolve a lot of the problems...

    Posted 8 years ago on Sunday November 25, 2012 | Permalink

This topic has been resolved and has been closed to new replies.