PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notifications are sent to users without being turned on

  1. sboisvert@bryxal.ca
    Member

    If the subject line and message of an email notification to users had previously been filled out, an email would be sent to our users even though the "Enable e-mail notification to users" checkbox was not checked.

    To rectify this problem, we simply deleted all the information in each of the fields. However, I think unchecking that checkbox should prevent users from receiving these emails even if the fields are filled. Can this problem be fixed?

    Posted 6 years ago on Monday February 4, 2013 | Permalink
  2. That has never been my experience with Gravity Forms. I just tested, and this did not happen. I had a form with a user notification configured. I tested the form and received the user notification as expected. Then, I unchecked the "Enable email notification to users" box, saved the notification settings, and submitted the form again. I did not receive a user notification.

    If you are receiving notifications with this box unchecked, there is something else going on. Please be sure you have the latest Gravity Forms and WordPress versions. If that is already true, please begin troubleshooting by checking for theme and plugin conflicts using these instructions http://rkt.gs/testing

    Posted 6 years ago on Tuesday February 5, 2013 | Permalink
  3. scangroup
    Member

    Is there any update or more information regarding this problem? I am experiencing the same, or a similar, problem. In our situation, we have a form that has user notifications turned off, but randomly (twice now) we will get a reply from the user asking why they got the notification. When I go into that form's notification configuration, the user email box is checked. Somehow it is turning user notifications on by itself. For most of our forms we DO want user notifications sent, but this is the only form where we do not want them sent, so I cannot verify that this happens with any other forms. The form in question is used internally to allow sales reps to log sales calls. Having this information sent to the customer without us knowing could have disastrous consequences. My only thought at this time is to put some code in place as a safety net by hooking into GF and checking that there is no user notification being sent. I have not researched if/how this can be accomplished, but I remember there being a hook related to notifications that should do the trick perhaps.

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink
  4. David Peralty
    Administrator

    Again, there isn't anything in our code that would make this happen. Is there any possibility that another site admin is turning it on? Either way, we do have a hook that you can use in your theme's functions.php file to disable it completely:
    http://www.gravityhelp.com/documentation/page/Gform_disable_user_notification

    Posted 6 years ago on Tuesday March 19, 2013 | Permalink