PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notifications go to user, but not administrator email

  1. Although I've seen a couple of GoDaddy-related issues posted, I have not seen one similar to this. The site is using the most current version of WP (3.1.2), and Gravity Forms 1.5.2, and the client has a number of other sites with GoDaddy right now so moving is not really an option we want to jump to yet.

    Specifically, the issue is that emails are being sent to the user, but not the administrator. The information is being written to the database as normal.

    Example 1: Set admin email to an email address off domain (not a free email service, but my domain account). Result: The user (an @yahoo.com address) does get the autoresponse email, but the admin account does not get the email.

    Example 2: Set admin email to an email address @yahoo.com. Result: The user (my personal domain email) gets the email and everything works.

    What the heck?

    I guess my first step would be to try WP-SMTP plug in, but GoDaddy is NOT hosting the email for the client. It is elsewhere on an Exchange server.

    Suggestions?

    Posted 8 years ago on Thursday May 5, 2011 | Permalink
  2. If the emails are going to the User but not the Admin then there is no issue sending emails. They both use the exact same function to send email, no difference.

    If the email is not being hosted by GoDaddy then the issue is most likely related to server configuration. The web server does not know it's not hosting the email and is trying to route it internally. Therefore it's never being sent out.

    This is a common issue when users host their email remotely but their web server isn't configured to know that. In CPanel it's a matter of changing email so that it is sending remotely. I don't know how to configure it in GoDaddy, you will need to discuss this with GoDaddy.

    What you need to tell GoDaddy is your email for that domain name is hosted elsewhere, not with GoDaddy, but your GoDaddy hosted site is not routing email to it when sent via PHP. They should be able to assist you with what needs to be changed on the server.

    Posted 8 years ago on Thursday May 5, 2011 | Permalink
  3. Thank you - but there is a twist happening here that I just don't get.

    If I set the admin email to someone@yahoo.com, the email gets sent to the admin account (someone@yahoo.com) and the user/submitter. That would indicate the server has no problem sending email to an admin account that is not hosted at the server.

    As soon as I change it to my domain's address (steve@mydomain.net) or the client' address - again, neither hosted on GoDaddy - the email is not passed on to that admin account, but it does go to the user.

    Confusing...

    Posted 8 years ago on Thursday May 5, 2011 | Permalink
  4. @spidercreations Yes, that is what I described above. It's a web server configuration issue. You need to tell your web server that your email is hosted remotely. What is happening is it doesn't know your @mydomain.net email address is hosted remotely so it's trying to route it internally because it think it's hosting your email. You need to tell your web server that the email for that domain is hosted remotely. You may need to check with GoDaddy to find out how to do this.

    Posted 8 years ago on Thursday May 5, 2011 | Permalink
  5. I'm seeing what might be something similar on the website westerlyenright.com

    Email & domain for this account is hosted through Verizon, site itself is hosted at Hostgator. Godaddy is not involved.

    as the developer, I can receive email messages if I put any of my email addresses in business, gmail or yahoo.

    However, if we put an email in from an @westerlyenright.com or a gmail address from a person, they do not receive an email.

    Does the email address in the gravity form administrator field, need to be an administrator for the wp installation itself too? Do this only send to the primary (first) administrator in wordpress?

    Posted 8 years ago on Friday May 6, 2011 | Permalink
  6. @brettbum No, as I explained above you need to contact your web host and find out what control panel setting needs to be changed on your site. The problem is your web server doesn't know your email is hosted remotely, so when it tries to send email to an email address using the same domain name as the web site... it never sends it because it tries to deliver it locally. Contact your web host, and explain to them that PHP is unable to send email to emails at that domain name and that your email is hosted remotely. They should be able to assist you in making the settings change. In CPanel this involves setting email to be routed remotely and not locally.

    Posted 8 years ago on Friday May 6, 2011 | Permalink
  7. Thanks for some reason that made more sense the second time. Although it did work for some external gmail accounts and not others . . . (regardless will troubleshoot with hostgator first and go from there) :)

    Posted 8 years ago on Friday May 6, 2011 | Permalink
  8. For Posterity (might help others with similar questions) Hostgator informed me that they need the email server name information such that we can create an MX entry to let the web host server know about the email host.

    In our case our email hosting entries are set up at a domain level. (I've worked on other sites where the MX entries were sometimes set up at the website server level)

    Posted 8 years ago on Friday May 6, 2011 | Permalink