PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notifications not sending - other plugins sending email fine using wp_mail()

  1. bkmacdaddy
    Member

    Contact Form 7 and Simple Modal Contact Form are sending emails to various addresses fine, but I can't get Gravity Forms to successfully send admin notifications. I tried installing WP Mail SMTP to see if that would help but I get an error when sending a test email using SMTP. That same plugin sends a test email fine when NOT using SMTP. I am at a loss.

    Posted 11 years ago on Wednesday November 17, 2010 | Permalink
  2. bkmacdaddy
    Member

    I got it to work using SMTP but only the notification to users is working. The admin and BCC notifications are not working.

    Posted 11 years ago on Wednesday November 17, 2010 | Permalink
  3. If you aren't receiving admin or BCC notifications it could be because of how your email is setup.

    Is the email you r are sending the admin notification to using the same domain name as the site? Are you using Google Apps for your email? If so, depending on how it's configured it may be getting rejected by Google Apps.

    Posted 11 years ago on Wednesday November 17, 2010 | Permalink
  4. bkmacdaddy
    Member

    I'm using the "Routing" setting with BCC's to my personal email address (not on the same domain) as well as the main WP admin (which is on the same domain). Neither are using Google Apps. The user email I created for testing is Gmail, and that works fine. Basically, it seems everything is sending for the user notification section but not admin notifications. I've tried a few different addresses in the BCC fields but get nothing.

    Posted 11 years ago on Wednesday November 17, 2010 | Permalink
  5. Admin Notifications and User Notifications are sent the same way. We haven't had any other reports of this issues so it's going to be a hosting environment related configuration issue.

    If you have tried the SMTP plugin and received an error when sending a test email with it then you didn't properly configure the SMTP settings. The SMTP settings have to be properly configured, on top of activating the plugin, in order for it to work properly. I would suggest trying this first, you may need to get with your web host to get the proper SMTP settings.

    Posted 11 years ago on Wednesday November 17, 2010 | Permalink
  6. Well, you can add another report of the exact same issue to this thread.

    Notification emails work fine to the person filling out the form, but the notifications to the "admin" don't ever get sent.

    There is something in the code somewhere that will not allow gravity to send to an email address that IS NOT the same as the domain name, and it doesn't seem to have anything to do with wether or not SMTP is installed or not.

    Posted 11 years ago on Wednesday December 1, 2010 | Permalink
  7. There is nothing in the code that prevents Gravity to send to an email address that is not the same as the domain name. If you aren't receiving emails to the Admin Notification email then it is most likely some sort of issue with your web server sending email to that domain.

    If you are using Google Apps for your email, for instance, if your DNS is not setup properly with your web host for your mail setup then you can run into problems sending email from PHP to a Google Apps hosted email. This is a web server related setting, not a Gravity Forms issue.

    Gravity Forms simply calls the wp_mail() function and passes the values. It doesn't have it's own sendmail code.

    Posted 11 years ago on Wednesday December 1, 2010 | Permalink
  8. homegrownacres
    Member

    Add another. I'm having the same problem; the user gets the notification but I don't get it from my default or BCC address.

    Every other form I have tried works fine. My default email address uses the same domain as my website and I'm not using the SMTP plugin.

    There is a problem here.

    Posted 11 years ago on Thursday December 2, 2010 | Permalink
  9. @homegrownacres Read my reply directly above yours. If your default email address uses the same domain as your website then there is some sort of configuration issue (common
    with Google Apps hosted email) that is causing you to not receive the email.

    We had the same exact issue with our own forms due to Google Apps email not being setup properly and we had to contact BlueHost, they corrected the issue on their end and we were then able to receive email to our Google Apps email from Gravity Forms correctly.

    Can you verify that if you change the send to email address to an email not associated with your domain that it does send? If so that shows that Gravity Forms is sending email.

    Where is your email hosted? Are you using Google's email service?

    Posted 11 years ago on Thursday December 2, 2010 | Permalink
  10. Can't get it to work with an apps address and with a separate non apps address. Can you tell us what bluehost did?

    Posted 11 years ago on Tuesday December 7, 2010 | Permalink
  11. @ryanopaz I'm not 100% sure what the change was that they made. We called them up and told them we were using Google Apps and that our PHP was not able to send to that email address from the same domain and they made a change on their end and it resolved the issue.

    It's a web hosting email routing issue. Contact your host and they should be able to assist you with this. Doing a search on google for "PHP Google Apps Email" turns up numerous discussions regarding this issue and it's a setup issue.

    Posted 11 years ago on Tuesday December 7, 2010 | Permalink
  12. Here's the answer:
    Those domains can have their mail preference set up by going into the "Edit
    DNS zone" and change the mail from local or automatic to the remote setting.

    From my host...it's a simple DNS setting change that is needed! :)

    Posted 11 years ago on Tuesday December 7, 2010 | Permalink
  13. chuckee
    Member

    I'd like to add myself as another person who is unable to receive admin emails when I am sending to an email address at the same domain name of the website.
    When I change the admin email address to something else, it works, but this is not the best solution.
    I suggest that the programmers behind GravityForms look into this please :)

    Posted 11 years ago on Thursday December 9, 2010 | Permalink
  14. @chuckee This isn't a Gravity Forms issue, it's a web server configuration DNS issue as @ryanopaz stated above.

    You have to setup your hosting so that your DNS zone is setup so that mail uses the remote setting rather than local or automatic. This way your web host sends the mail remotely.

    The problem is your web server doesn't know your email is being hosted remotely and assumed it is hosted locally, so it's never sending the email out to the remote server and is holding it thinking it also hosts your email.

    You may need to contact your web host and explain the issue, you can explain mail is arriving to other domains but not to your domain when sent from the same domain. Explain to them what I said above and what @ryanopaz said above. It's a DNS setting change.

    See this post, the 1st response on this post that is marked "Best Answer" explains the situation in detail:

    http://www.google.com/support/forum/p/Google+Apps/thread?tid=179686d4bd75d3d2&hl=en

    Posted 11 years ago on Thursday December 9, 2010 | Permalink
  15. chuckee
    Member

    I've been playing around with this got some advice for people here:
    Create a PHP file on your webserver with the following contents (edited for your email address) to see whether it can send an email using PHP's mail function.
    Then, open this PHP webpage from a browser.
    In my case, the PHP mail function *cannot* send to an email address at the same domain name as my website - this confirms what has been said above. The problem is with my webhost.

    <?php
    $to = "your@emailaddress.com";
    $subject = "Test mail";
    $message = "Hello! This is a simple email message.";
    $from = "your@emailaddress.com";
    $headers = "From: $from";
    mail($to,$subject,$message,$headers);
    echo "Mail Sent.";
    ?>

    Sadly, my webhost (1and1) have said that they cannot provide any assistance to me, which is useless. They don't seem to care about VPS customers (or dedicated customers from what I hear).

    Posted 11 years ago on Friday December 10, 2010 | Permalink
  16. @chuckee That is terrible that 1and1 doesn't seem to be able to provide assistance. It's a DNS zone issue. A simple change to your DNS to tell your site to send email remotely rather than locally or automatic should solve the issue. I know other hosts, including BlueHost, have no problem assisting users with this change and a lot of hosts allow you to make the change within your cPanel. Do you have cPanel access with 1and1? If so check out the Google forum post I linked to above and see if you can follow those directions to make the change in cPanel yourself.

    Posted 11 years ago on Friday December 10, 2010 | Permalink
  17. chuckee
    Member

    Hi Carl,
    I called 1and1 again, and miraculously spoke to someone who could help me. He told me to do the following, in Plesk, which fixed the problem:

    Click on 'Domains' in the left menu. Then click on your domain name.

    Click on 'Mail Accounts' (this can be called something else depending on which version of Plesk you have).

    Click on 'Mail Settings'. Make sure that 'Activate mail service on domain' is *not* checked.

    The problem was that I was actually using 1and1.com's own mail server, and not the mail server located on my own server, so I shouldn't have had that box checked.

    Posted 11 years ago on Sunday December 12, 2010 | Permalink

This topic has been resolved and has been closed to new replies.