PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

notifications not sending

  1. Hi,

    I realize this is part RTFQ but I'm having problems with email notifications not sending. It's suddenly not working as of right now.

    I'm also on Godaddy Hosting as well. They recommended me to just change the SMTP server to relay. Test emails from the SMTP works but the emails from Gravity forms don't.

    Any other places I can check? Any ideas how to call boneheaded GoDaddy and tell them it's their issue?

    Example form below.
    https://lonelybrand.com/blog/white-paper-landing-page-guide-2013/

    Posted 8 years ago on Tuesday November 6, 2012 | Permalink
  2. David Peralty

    Have you tried using a SMTP plugin for WordPress? Gravity Forms uses WordPress' mailer for notifications. If you are looking for one, there are hundreds of forum posts about similar issues, including specific things people have done on Godaddy to get around such issues.

    Posted 8 years ago on Tuesday November 6, 2012 | Permalink
  3. I may have just fixed a strange situation of notifications not being sent.

    From a GF contact form on a new site notifications were not sent. Neither to the admin e-mail nor to the user. I tried to fill out and send the form with several e-mailadresses. No notifications came through.

    I had just launched this site for a client and I was still the only user. However I had changed the emailaddress in Settings>General to the emailadress of the site owner.

    Then I changed the general emailaddress back to my e-mailaddress that also belonged to my WP admin user account. Now upon resending all notifications were promptly sent and received.

    So it looks like there's a quirk when these two conditions are met:

    - from field of notification is {admin_email}
    - Settings>General Emailaddress is not present as an admin in WP users.

    I haven't tested this to the bottom, but since this behaviour is so strange, and the problem seems so common for GF users, I thougt I'd post this possible clue first.

    Posted 8 years ago on Wednesday November 7, 2012 | Permalink
  4. I've been having this problem for quite some time now, too. I tried e-rik's suggestion and made the email addresses identical between notifications and my admin email, but that doesn't seem to make a difference. For the record, I'm not on GoDaddy (Amazon).

    Any other thoughts?

    Posted 8 years ago on Thursday November 8, 2012 | Permalink
  5. David Peralty

    jonloomer - What else have you tried? Have you tried a SMTP plugin? Have you confirmed it isn't a Plugin/Theme conflict?

    Posted 8 years ago on Thursday November 8, 2012 | Permalink
  6. David -- I just activated an SMTP plugin, but I don't necessarily know what I'm doing with that. Didn't help though. I use Genesis. Any word of that being a conflict? Any particular plugins I should look out for that could be a conflict?

    Thanks.

    Posted 8 years ago on Thursday November 8, 2012 | Permalink
  7. David Peralty

    Hi jonloomer - ask your host for SMTP details, as that might help. As for conflict testing, please look at the following instructions:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    I don't know of any active issues with the Genesis theme, but caching plugins, and other plugins that control e-mails (including buddypress) can interfere.

    Posted 8 years ago on Thursday November 8, 2012 | Permalink
  8. I'm having the same problem. Forms were sending fine until 5 November. I installed a GF update yesterday because the forms were behaving erratically in Firefox (checkboxes disappear as you mouse over them, fine in Chrome). Now checkboxes still disappear and emails no longer send to registrant or admin.

    Posted 8 years ago on Friday November 9, 2012 | Permalink
  9. David Peralty

    cshaffstall can you create your own support thread as we will need to have a back and forth conversation with you on both your issues if you want proper assistance.

    Posted 8 years ago on Friday November 9, 2012 | Permalink