PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Notifications rules not being obeyed on form submission

  1. Hi guys,

    I have just been creating some new forms this morning and I have noticed that upon submission a couple of the rules I have set in the notification settings are not being obeyed.

    Notifications are sent to the admin and user just fine but it's the email address settings that don't seem to be obeyed.

    No matter what I set as the 'From Name' and 'From Email' it appears that the defaults are still used.

    So the notification comes from my site's name and then the address of noreply@mysite.com

    It's not a huge issue, but would be nice to mask the reply address and from name, so that users can reply directly to the notification email.

    Could someone test this on their install with the latest version of GF 1.6.4.5 and see if they get the same.

    Simply set the from name and email address and see if it's obeyed.

    Thanks so much :)

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  2. I just tested my installation and that is not my experience. I received the email from the address I set in the notification area, and the name was preserved as well. I am using the latest Gravity Forms and WordPress. I'm not using any special plugins to deliver mail.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  3. Hmm... How strange.

    I don't have any specific plugins installed to deal with mail either.

    I'll do some more testing with plugins and get back to you.

    Thanks for checking.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  4. Please do check for a plugin conflict. It could also be server configuration.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  5. Hi Chris,

    Done some debugging and it's surprisingly a Gravity Forms and Buddypress conflict.

    When BP is deactivated, the email settings work just fine.

    I'm not sure which of the 2 plugins is causing the conflict though, or which would be easier to patch to stop it.

    Do you have any installs running the latest version of BP to test?

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  6. I do. On that installation I use the "Mail From" plugin to work around it. http://wordpress.org/extend/plugins/mail-from/

    It's an old plugin, but it still works with WordPress 3.3.1 and BP 1.5.1 (I think those are the versions.)

    That will not solve the problem of being able to set the From and Email address on each form, but it worked in my situation. Beyond that, I did not look into the cause of the conflict.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  7. Hey Chris,

    So in terms of setting the from name and email, do you think it's one for the GF' team, or the BP team?

    Like I say, the emails themselves are still being sent which is cool, but the name and from address would be great to have working when BP is active.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  8. I'm not sure where the conflict comes from. I never looked to far into it. I was able to work around it in my situation and never went further. If I had to guess, I would guess it's BuddyPress. I never looked into the filters or hooks being used by BuddyPress to see if they're intercepting the mail and processing it somehow.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  9. I'll speak to some of the BP devs and see if they know what's happening.

    BuddyPress is such a big platform, as is GF. They have to work together if possible.

    Cheers Chris.

    Posted 9 years ago on Saturday June 30, 2012 | Permalink
  10. Please update us here if you find out what's going on.

    Posted 9 years ago on Sunday July 1, 2012 | Permalink
  11. I'm experiencing the same problem with my form. Instead of appearing as my email address and name in the users email it's appearing as accountname@box***.bluehost.com. The admin email in WP settings is set to where I want it to go (support@themightyshrimp.com), but it doesn't appear in the users email anywhere. I'm running email through Google Apps. The same kind of form on other sites of mine work just fine.

    Posted 9 years ago on Wednesday August 1, 2012 | Permalink
  12. David Peralty

    For you TheMightyShrimp, I recommend installing and configuring a SMTP plugin for WordPress.

    Posted 9 years ago on Wednesday August 1, 2012 | Permalink
  13. Worked like a charm. Much obliged David.

    Posted 9 years ago on Wednesday August 1, 2012 | Permalink
  14. David Peralty

    Glad to hear it. Sometimes the default WordPress sendmail files that Gravity Forms hooks into don't work as well as they should.

    Posted 9 years ago on Wednesday August 1, 2012 | Permalink
  15. Another member (lonut) recently sent me this work around he used:

    I've found out what the problem was. This function in wp-content/plugins/buddypress/bp-core/bp-core-filters.php. I've removed it and everything works as it should.

    * bp_core_email_from_name_filter()
    *
    * Sets the "From" name in emails sent to the name of the site and not "WordPress"

    Maybe that will help someone.

    Posted 9 years ago on Monday November 26, 2012 | Permalink