PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

One site, two forms, only one sends notifications to admin

  1. On this site: http://vedicworld.org/ I have two forms. A contact form: http://vedicworld.org/contact-us/ and a payments http://vedicworld.org/payment/. From what I can tell, both notifications are configured the same with the exception that the contact form sends all fields and the payment form does not.

    The issue is the payment form is sending out notifications to the admin but the contact form is not. I tried setting up a notification to the user and that was received but nothing to the admin.

    I have the SMTP plugin installed. I even set up a new test form and tried that, no notifications either. All email is sent out to an address on the domain so it shouldn't be blocked. This makes no sense, please help.

    Posted 11 years ago on Tuesday February 22, 2011 | Permalink
  2. We can take a look and see what is going on. Please send us a WordPress admin login for the site via our Contact Us form and reference this forum post.

    Posted 11 years ago on Tuesday February 22, 2011 | Permalink
  3. I sent the access information yesterday but I have not heard back. Oddly, I changed the email for admin notifications the other day for the contact form to 'creativeliza@gmail.com' and I got a notification from someone who used the form. I was all excited thinking it was fixed. So I changed the email address to "test@vedicworld.org" which forwards to my email as well, tested the form and nothing came. I'm really stumped.

    Posted 11 years ago on Wednesday February 23, 2011 | Permalink
  4. Was just about to respond. The reason why it worked to your @gmail.com account and not your @vedicworld.org address is because it's a web hosting configuration issue related to your email.

    This is common if the email is hosted elsewhere (ie. site hosted with your web host and email hosted using Google Apps) but sometimes happens when both are hosted at the same location.

    What is happening is your web server thinks it hosts your email so it's trying to send the email internally, but because your email isn't hosted locally it's not sending the mail out remotely.

    This is why the email arrives at GMail but not when trying to send to an email that uses the @vedicworld.org domain name.

    Is your email being hosted somewhere other than your web host?

    Posted 11 years ago on Wednesday February 23, 2011 | Permalink
  5. jamesglenos
    Member

    I am having the same issue as Creativeliza. I host my website (Namecheap) and e-mail (Google Apps) separately, as Carl mentioned. I have two forms; sometimes my notification e-mails work, sometimes they don't.

    So, what's the fix for this?

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  6. @jamesglenos This is a web hosting configuration issue. Your web server doesn't know it isn't hosting your email so it is trying to route it internally rather than sending it out remotely so it never gets to your Google apps hosted email account.

    Here is the official support article from Google on this issue:

    http://www.google.com/support/a/bin/answer.py?hl=en&answer=55299

    Here is a more specific answer to this in the Google Apps help forum:

    http://www.google.com/support/forum/p/Google+Apps/thread?tid=179686d4bd75d3d2&hl=en

    To sum it up you need to tell your web server that your email is hosted remotely so it will send it remotely. Contact your web host to find out specifics on how to do this. It's typically a control panel settings change.

    Explain to them the email for your domain name is hosted with Google Apps and email sent via PHP on your web server is not arriving to those accounts but it is arriving to accounts not associated with your domain name. They should be able to assist you. You can show them the first Google link above which should provide them with enough information to assist you in correcting the issue.

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  7. jamesglenos
    Member

    Carl,

    Thanks for awesome and quick reply. I've changed my settings in cPanel to "Remote Mail Exchanger" and I inputted all the MX records for Google Apps. Things still aren't working, so I'm in the process of getting in touch with my host about this now.

    There's another issue, though. Like I mentioned, I've had notification e-mails work before when sending outside the domain (to a regular Gmail account), but right this moment even that isn't working. It seems very sporadic. Any ideas?

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  8. It could be a host related issue. I know some hosts are known to queue emails, and some hosts are just generally unreliable when it comes to sending email. We rely on the wp_mail function to send email which relies on your web servers ability to reliably do so.

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  9. The email and the site are both hosted by the same company although I believe that they have different servers set up for this. The issue seems to be that the notifications are sporadic.

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  10. If the notifications are sporadic it's going to be an issue on the server itself sending the emails. Notification emails will only be as reliable as the web server that is sending them. Gravity Forms calls a built in WordPress function to send the email.

    Posted 11 years ago on Thursday February 24, 2011 | Permalink
  11. I have recently been experiencing the same problems. I host with Rackspace Cloud. Upon contacting them I was told the following (by the way, their customer support is top notch, much like GF):

    "To guarantee delivery I would modify the form mail script to authenticate to our mail server. That is more reliable that using our mail relay. Mail relay doesn't always work since bulk email is sent that way. I would use smtp authentication on your form mail script, then it will work everytime."

    I am going to try a plugin called Configure SMTP, which was recommended to me by another source . I'm guessing this should do the trick.

    Posted 11 years ago on Sunday April 3, 2011 | Permalink
  12. realph
    Member

    I'm having the same problem, my basic form with 3 fields seems to work, but my registration form with multiple fields (Paragraph Text) doesn't seem to send the notification to my email. Can anyone help me?

    Posted 11 years ago on Sunday April 3, 2011 | Permalink
  13. @Luke Yes, you would need to implement an SMTP plugin. WP Mail SMTP is another one you could try.

    @realph If one form sends notifications, then Gravity Forms is able to send the notifications. It all uses the same code. Are they being sent to different email addresses? If so it's probably email address specific. Please supply more details, such as the email addresses each one is going to, etc.

    Posted 11 years ago on Monday April 4, 2011 | Permalink
  14. Hey Carl, having a similar issue. I have one contact form, and in one part of it, it has a drop down where the user has about 6 options to choose from. In the Notifications area, I have it setup to email 2 different people for each different choice selected from the dropdown. The only problem is that 2 people are not receiving email notifications, and they both are selected for the last option in the dropdown.

    Are you thinking it's the same issue as mentioned above?

    We're using Google Apps as well for our domain, but the 2 who aren't receving the email notifications are using their company's email address.

    Posted 10 years ago on Saturday October 8, 2011 | Permalink
  15. I was having the same issue (form sends emails to gmail/yahoo addresses but not to the address with the domain name. My site is hosted at Bluehost and the email is managed elsewhere. As mentioned above, that was the problem. Bluehost walked me through changing the DNS zone and it fixed the issue. Here's how:

    1. Go to the cPanel, scroll down to Domains and click DNS Zone Editor
    2. Select the domain from the dropdown menu and then scroll down to MX (Mail Exchanger) records
    3. Where it says, "Email Routing: Automatically Detect Configuration:Auto more ยป" click "more >>"
    4. Change the routing to Remote
    5. Save
    6. That's it. Test it.

    Note: Keep in mind that this is only for mail that is hosted remotely- that wouldn't change anything for mail that is hosted on Bluehost. Bluehost emails would work for outgoing mail, but not incoming mail.

    Posted 10 years ago on Tuesday January 31, 2012 | Permalink