PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Page load time with gravity form

  1. masok88
    Member

    Hi,

    I've got an issue with a page with gravity forms on it, namely the form is loading after the rest of the page. Is there a way I can change this? As its namely affecting the page layout in a noticeable way as the page loads.

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  2. Richard Vav
    Administrator

    Could you post a link to your page so we can see exactly what is going on?

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  3. masok88
    Member

    The password is 13north

    http://www.comparelifequotes.co.uk/about-your-life-insurance-policy/

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  4. masok88
    Member

    I've just realised the form isn't submitting either. Is their a reason this could be happening? I'm not getting any validation either.

    Update: It is submitting information (getting a confirmation email/database submission) but Its' not redirecting to where I specify nor giving any validation messages. Thoughts?

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  5. Richard Vav
    Administrator

    I see what you mean, there is definitely a short delay there, it's more noticeable in IE than in chrome. After taking a quick look at your source code there are a couple of issues which may or may not be delaying the load.

    You are loading jquery multiple times, once up in the head and once down in the footer, if you have manually included jquery so should remove that call and enqueue it instead which prevents it from being loaded separately by each plugin that requires it.

    Down in the footer you are also calling script.js and plugin.js which don't exist so you getting 404 errors because of that.

    input_1_12 by the looks of it should have the enhanced ui applied to it but it isn't so I would suggest you work though the plugin/theme conflict steps to find the exact culprit, although I have a feeling it could be the plugin/script that concatenated and minified your css/js
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  6. masok88
    Member

    thanks so much! Do you know why the form isn't submitting either? Is their a reason this could be happening? Could it be down to a theme / plugin conflict?

    UPDATE: seems to be a theme issue thats stopping the rich ui coming in to play. Have solved it and haven't checked script condenser but the delay still seems to be occuring. Am now getting validation and I guess proper after-submission functions.

    Posted 10 years ago on Monday January 23, 2012 | Permalink
  7. Richard Vav
    Administrator

    Good to hear that you have sorted out your theme issue.

    One thing I would point out, it looks like you have ajax enabled. There is currently a bug in gravity forms that strips the enhanced ui from enabled drop downs when validation fails with ajax turned on, if you want your form appearance to remain as consistent as possible you might consider disabling ajax on that form until they get that bug fixed or disable the enhanced ui on the drop downs.

    Also which web browser are you using, have you tried running the YSlow extension which is available for both chrome and firefox, it can usually point out some areas that can be improved to speed up page load times.

    You might also consider using a service like http://www.cloudflare.com (free) which when enabled acts like a bit like a cdn caching some of your files to help speed up delivery as well as optimising css, js and html.

    Posted 10 years ago on Monday January 23, 2012 | Permalink
  8. masok88
    Member

    wow thats great, I'll look into that! I've been using chrome so I'll get on installing yslow and I'll check out cloudflare.com later today.

    Thanks!

    Posted 10 years ago on Monday January 23, 2012 | Permalink