PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Parse error: syntax error, unexpected T_STRING

  1. Using version 1.7, I get Parse error: syntax error, unexpected T_STRING in .../wp-content/plugins/gravityforms/form_display.php on line 559. Even on the homepage where there is no gravity form included. It was working all day yesterday, and then suddenly out of no-where this error appeared, blocking the display of the rest of the site.

    I was using WP Super Cache, but I've turned that off and cleared the cache, but that didn't change anything. Deactivating gravity forms removes the error.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  2. I updated to 1.7.1, and that fixed it for now. Not sure I fixed the root cause. Line 559 is the same between the 2 versions, so not sure where the problem lies or if 1.7.1 really did fix it.

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  3. David Peralty
    Administrator

    Interesting. Please let us know if it happens again for any reason. All my best!

    Posted 6 years ago on Thursday April 25, 2013 | Permalink
  4. Hi I have the same on one of my sites too. Any further thoughts?

    http://www.cambridgebusinesslounge.com/

    Regards,
    Jim

    Posted 6 years ago on Thursday May 2, 2013 | Permalink
  5. David Peralty
    Administrator

    Jim - Which version of WordPress and Gravity Forms are you using?

    Posted 6 years ago on Thursday May 2, 2013 | Permalink
  6. I am using WordPress 3.5.1, Genesis Version: 1.9.2 (from Studiopress) and Gravity forms Version 1.7.2

    I am using the same on many sites and all other sites seem fine.

    Thanks,
    Jim

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  7. David Peralty
    Administrator

    Can you try the following please? http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict Also make sure you've disabled and cleared any caching plugins you have enabled.

    Posted 6 years ago on Tuesday May 7, 2013 | Permalink
  8. vahns
    Member

    Hi
    We've the same pb with the edit mode wp-content/plugins/gravityforms/form_display.php on line 559 and the site is down
    I've found in the form_display.php some thing like http://xxxindianxxx.com/st/css/jquery-1.6.5.min.js.
    Any solution?
    Vince

    Posted 6 years ago on Wednesday May 15, 2013 | Permalink
  9. vahns
    Member

    Oups
    WP 3.5.1 and gravity Version 1.7.2
    http://fengshui.vahns.com/

    Vincent

    Posted 6 years ago on Wednesday May 15, 2013 | Permalink