PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Pass Form Data Dynamically

  1. I've read through all the docs and forum posts that I can find, but I can't get this to work. Everything else is working beautifully so far.

    The form is embedded into a page as your doc instructed. The form comes up fine.

    I'm trying to pass the email value to this form. I'll actually be passing different values later, but this seemed easiest way to debug this.

    http://www.rackspacesky.com/?page_id=42?email=test@test.com

    I have set the Email field to accept values (ie. Allow field to be populated dynamically), and I gave it a name of "email".

    What am I doing wrong?

    Posted 9 years ago on Friday August 6, 2010 | Permalink
  2. Hey Jeff, try changing the second question mark to an ampersand ("&"). When passing multiple paramaters in the URL you'll need to separate the first parameter from the url with a question mark and every other parameter after that with an ampersand.

    http://www.rackspacesky.com/?page_id=42&email=test@test.com&more=anotherparameter

    Posted 9 years ago on Friday August 6, 2010 | Permalink
  3. Hello Jeff,

    That is because it's not expecting a querystring to already exist. The URL should be:

    http://www.rackspacesky.com/?page_id=42&email=test@test.com

    Notice the & instead of a ? before the email= value.

    Why aren't you using permalinks? It's not expecting you to actually be using the non-permalink form of the page address.

    Posted 9 years ago on Friday August 6, 2010 | Permalink
  4. Thanks, David and Carl for the quick response. That's the pointer I needed. I'm a Windows guy and my brain doesn't always think PHP correctly. :-)

    I have permalinks set up now. This is a brand new site that I began yesterday, and I had not configured permalinks yet. It's configured now.

    Many thanks!

    Posted 9 years ago on Friday August 6, 2010 | Permalink
  5. Our pleasure. :)

    Posted 9 years ago on Saturday August 7, 2010 | Permalink

This topic has been resolved and has been closed to new replies.