PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Passing Info to a form with a URL

  1. So basically, what I want to do is to be able to construct URLs to send clients and when the click them to go to the form, whatever I have added into the URL will populate the form fields.

    So for instance, I know I am charging them $15/month for hosting, I want to be able to construct a URL that will put 15 into the form field for monthly cost.

    From my research on here I would have thought that

    .com/form-page/?cost_month=15

    would have worked. (I did checkmark "Allow field to be populated dynamically" and set the field to be cost_month)

    It doesn't work for me though. What am I missing?

    I did read this page too http://www.gravityhelp.com/documentation/page/Allow_field_to_be_populated_dynamically

    Posted 10 years ago on Wednesday October 19, 2011 | Permalink
  2. Sounds like you did everything correctly.

    The parameter names are case sensitive. Be sure you have them identical.

    Can you post a link to your form? It's possible there is something happening with the rewrite that makes the parameter go away. Be sure you use a trailing slash (after the form-page as you have it), or not, and use www or not. You want to avoid a redirect before they get to the page with the form on it.

    Posted 10 years ago on Wednesday October 19, 2011 | Permalink
  3. Many thanks for the help

    http://limecuda.com/hosting-agreement/

    Here is what the URL field looks like: http://screencast.com/t/bTrl02XX

    Not sure if this complicates things but this is the nightly build of WP. It is using postname as the url http://screencast.com/t/VPndn9p7wA - i resaved it in case that was it.

    Posted 10 years ago on Wednesday October 19, 2011 | Permalink
  4. What would a link look like that you send to one of your customers, with the query string?

    What version of Gravity Forms are you using?

    Posted 10 years ago on Wednesday October 19, 2011 | Permalink
  5. It was 1.5.3 but I went ahead and updated to the 1.6 RC5

    I would do something like http://limecuda.com/hosting-agreement/?site_url=http://clientsite.com&?cost_month=25

    So it would populate with their url and the price i have given them.

    Posted 10 years ago on Thursday October 20, 2011 | Permalink
  6. Can you try it with the default permalinks? It looks like WordPress is stripping out the query string rather than capturing it.

    Posted 10 years ago on Thursday October 20, 2011 | Permalink
  7. That failed too :(
    http://limecuda.com/?page_id=755/?cost_month=15

    I wouldn't be able to live with that either of course.

    I can give you access to this site or I can just live with it.
    Seems quite odd.

    Posted 10 years ago on Thursday October 20, 2011 | Permalink
  8. The URL without permalinks should look like this:
    http://limecuda.com/?page_id=755&cost_month=15

    Obviously the permalink change would not be permanent, just for debugging. There is something strange going on with your rewrites. Sometimes the query string is dropped, sometimes it's not.

    Please do send me access to the site via email at chris@rocketgenius.com

    Is this a live site? Thanks.

    Posted 10 years ago on Thursday October 20, 2011 | Permalink
  9. With help from Chris I figured this out. Turns out there was a little setting checked in Yoast's SEO plugin that said:
    "Redirect ugly URL's to clean permalinks. (Not recommended in many cases!)"

    This was one of those cases. So if anyone has a problem with that query being stripped out, make sure you don't have that setting checked if using that plugin. Dumb mistake on my part having that checked.

    Thanks Chris for all your help!

    Posted 10 years ago on Friday October 21, 2011 | Permalink
  10. GAH!

    I hope that's it. Thank you for helping resolve that one.

    Posted 10 years ago on Friday October 21, 2011 | Permalink

This topic has been resolved and has been closed to new replies.