PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Payment pending and no site notifications

  1. paulleeson
    Member

    Hi,

    I have a PayPal form set up which is set to only notify once payment has gone through PayPal.

    After completing payment though the entry stays as PENDING and no notifications are sent.

    I have checked the IPN and this is set correctly.

    Many thanks for your help. I am happy to email through the logon details for you to check.

    Paul

    Posted 10 years ago on Monday December 19, 2011 | Permalink
  2. This is happening because something is preventing the PayPal IPN from communicating with your site. The payment status is updated when the IPN is processed by Gravity Forms.

    Here are the first two things I would check:

    1) Check your IPN History in PayPal and look at the history for some of the transactions and see if they were successful or if they failed. If they failed, see what the error was.

    2) Check the PayPal Email you have configured in your PayPal Feed for that form. Make sure this is the PRIMARY email address associated with that PayPal account. If your PayPal account has multiple email addresses associated with it and the email you have configured differs from the email address PayPal passes back in the IPN request... the IPN request will fail validation and won't be processed by Gravity Forms.

    Let me know how it goes.

    Posted 10 years ago on Monday December 19, 2011 | Permalink
  3. paulleeson
    Member

    Hi Carl,

    Sorry, I found the answer.

    The client had set it so that they manually accept / confirm payments in their PayPal settings so GF obviously was not getting the signal that the payment had gone through.

    Sorted after switching this setting back...

    Cheers,

    Paul

    Posted 10 years ago on Tuesday December 20, 2011 | Permalink

This topic has been resolved and has been closed to new replies.