PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

PayPal IPN URL Failing

  1. islandip
    Member

    Hi,

    A client is getting a message from paypal stating the following:

    "Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    http://www.waifanimals.org/?page=gf_paypal_ipn

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account."

    I have attached screenshots of what I currently have setup on their wordpress site and paypal. paypal isn't showing any IPN history for some reason. Any help would be great. http://www.islandipllc.com/troubleshooting/paypal-ipn.jpg

    Gravity Form URL: http://www.waifanimals.org/support/

    Posted 6 years ago on Friday October 12, 2012 | Permalink
  2. Email me at rob@rocketgenius.com and I can give you a logging plugin that hopefully will show you what's going on here. Just reference this post.

    Posted 6 years ago on Friday October 12, 2012 | Permalink
  3. Your IPN URL returns a 200 Success header, which is expected and should work. I was able to load the URL in a browser without a problem. If PayPal cannot access that URL, it's possible something on the host is blocking their requests, maybe a firewall or security setting. It appears that you have everything configured correctly. I would check with your host to see if there are access logs or error logs or firewall logs (maybe your cPanel has these logs accessible?) which would show what is happening with the requests from PayPal.

    I don't think you are doing anything wrong and PayPal is trying to do the right thing too, but it looks like the problem is communication between PayPal and your server. I would contact your host with this information.

    Posted 6 years ago on Friday October 12, 2012 | Permalink
  4. islandip
    Member

    Thanks for both your help. I deactivated the plugins Block Bad Queries (BBQ) and Wordpress Firewall 2 and the process seems to work now. So it looks like the issue may have been one of the two or both. I also installed the logging plugin and everything looked ok. I will let you know if anything changes but it looks like the issue is resolved.

    Posted 6 years ago on Friday October 12, 2012 | Permalink
  5. Either of those plugins could certainly be involved. Do either of them have any logging for the queries which are dropped?

    Posted 6 years ago on Saturday October 13, 2012 | Permalink