PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

PayPal notifications and status not working with IPN?

  1. wpfmon75

    So I've set up a form to allow people to purchase tickets and I route that over to PayPal via the add on to GF and the transaction occurs. IPN has also been setup in PayPal and the setting selected on the PayPal add-on.

    The setup is as follows:
    PayPal Email Address has been entered
    Mode is set to Production

    Do not prompt buyer to include a shipping address.
    Do not prompt buyer to include a note with payment.
    Send admin notification only when payment is received.

    The payments get processed at PayPal without any issues however, the integration back with GF doesn't seem to be working correctly. Here's what I observe:

    1. No notification is sent when the payment is received (I'm assuming that I should be getting a notification email from GF based on the Notification settings in the Form that I have created.
    2. I look at the entries for the Form I have created and and the "Payment Status" shows "Processing".
    3. I look at "PayPal Stats" and it shows "No payments have been made yet."

    I've looked in the PayPal account and I can see the payments getting posted at PayPal so something isn't sync'ing up correctly with GF.

    Any assistance on these matters would be appreciated.


    Posted 12 years ago on Monday September 26, 2011 | Permalink
  2. This is going to be a web server issue preventing the IPN request from being processed.

    You need to login to your PayPal account and go to the IPN History. Look at the IPN requests for that payment and view it, see what it's status is. If it says anything other than Sent then your server is rejecting the IPN request from PayPal.

    If the IPN History says "Sent" as the status for that IPN request then the issue is going to most likely be related to the IPN not verifying properly. When the status is "Sent" but the IPN isn't processed it is typically due to one of two things:

    - cURL is not installed properly or does not support the https protocol so the IPN request cannot be validated via a secure connection.

    - The Payment email address you configured in your Gravity Forms PayPal Add-On feed settings is NOT the primary email address on your PayPal account. If the email address used in your feed settings does not match the email address PayPal sends in the IPN request... it will not validate. This issue occurs when you have multiple email addresses setup for your PayPal account and you aren't using the primary one in the Gravity Forms settings.

    Posted 12 years ago on Monday September 26, 2011 | Permalink
  3. wpfmon75

    Thanks for the reply.

    I'll checked into the PayPal setup. The PayPal address in GF is the primary email address of the PayPal account. I see that in PayPal, the IPN History shows a message ID, a status, and a transaction ID. The status of the messages are "sent". I even attempted to resend the IPN notifications via PayPal and the status within GF / PayPal add-on shows "Processing".

    Thus, I'm led to believe that there is a problem with my hosting environment specific to cURL. I'll touch base with GoDaddy on this front and report back.


    Posted 12 years ago on Friday September 30, 2011 | Permalink
  4. You are correct. This sounds like a cURL issue. Most likely your cURL install doesn't have https enabled which means Gravity Forms can't do a secure cURL connection back to PayPal to verify the IPN.

    What happens when the PayPal IPN comes in is Gravity Forms takes the IPN and the connects back to PayPal to verify it is a valid IPN request. This is to prevent IPN spoofing. This is where the problem is, Gravity Forms is unable to verify the IPN most likely due to a cURL issue.

    This is why the entry still says Processing, yet the IPN history in PayPal doesn't appear to show any problems on the PayPal end of things because as far as PayPal is concerned it's IPN was sent and received.

    Posted 12 years ago on Friday September 30, 2011 | Permalink
  5. wpfmon75

    cURL is installed and enabled as demonstrated by the following phpinfo output:

    cURL support enabled
    cURL Information libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    I've also determined that the PayPal email address is indeed the primary email address for the PayPal account and is entered correctly in GF / PayPal add-on.

    How else can i troubleshoot this issue?

    Posted 12 years ago on Friday September 30, 2011 | Permalink
  6. It's not just an issue of cURL being installed, cURL also has to have https enabled so that it can communicate via https. So you need to check with GoDaddy to make sure it does.

    If they said it does, or they say they have fixed it and it still doesn't work just let us know and we can debug it and tell you the exact cause. But this is usually the cause.

    Posted 12 years ago on Friday September 30, 2011 | Permalink
  7. wpfmon75


    Thanks for the feedback, I'll reach out to GoDaddy and report back.

    Posted 12 years ago on Friday September 30, 2011 | Permalink
  8. wpfmon75

    I've finally gotten GoDaddy to look into this and according to them, they state that cURL is functioning as expected. Here is their statement:

    "I can confirm that cURL is functioning on the server since resolves our homepage successfully."

    "You may also wish to enable Error Logs as a temporary diagnostic measure. Our Linux-based hosting accounts let you enable Error Log collection for seven-day periods."

    My comments:
    Please note that I've masked our domain name with "" because I don't want it shown in this thread.

    So our request to Gravity Help, please help us debug this issue.


    Posted 12 years ago on Tuesday October 18, 2011 | Permalink
  9. That's not a really good test of cURL functionality with SSL, I don't think. (if you can post the contents of curl_test.php here we'd be able to tell for sure.)

    Can you try this from a command line, if you have a command line?

    curl -o test.html

    Posted 12 years ago on Wednesday October 19, 2011 | Permalink
  10. wpfmon75

    Don't have command line / SSH access, is there any other test that we can perform? I can download the curl_test.php file, modify it, and upload it to test if that's an option.


    Posted 12 years ago on Friday October 21, 2011 | Permalink
  11. Can you post the source of that file at or It's possible they are testing with SSL, but we won't know without looking at the code in the file. Thanks

    Posted 12 years ago on Friday October 21, 2011 | Permalink
  12. wpfmon75

    Please have a look:


    Posted 12 years ago on Friday October 21, 2011 | Permalink
  13. wpfmon75

    Also, I circled back with GoDaddy earlier today regarding cURL supporting HTTP and HTTPS and this is what they had to say:

    "There is currently no issue with using cURL on your hosting account to connect via HTTP or HTTPS. We have tested cURL on your hosting account using both HTTP and HTTPS and were able to make the request without issue. You will need to review your scripting to determine what may be causing any issues with your application.

    Please let us know if we can assist you in any other way."

    Posted 12 years ago on Friday October 21, 2011 | Permalink
  14. Sounds like they believe cURL to be working properly with SSL (and it was also in your phpinfo()). Their curl_test.php did NOT use https though, so that's not a good test. Maybe they modified the file and have tried it both ways - it's just not present in this copy.

    It's possible the issue with IPN is NOT due to lack of SSL support in cURL, but that is a common problem. It's a good place to start.

    Have you been able to enable logging to see what's going on, if anything?

    I will bring this to Carl's attention so he can take a look at it again.

    Posted 12 years ago on Saturday October 22, 2011 | Permalink
  15. wpfmon75

    Per my understanding, GoDaddy tried it with both HTTP and HTTPS and the current file is based on the HTTP test.

    I believe that I can enable logging for the web server logs - will the communication issue with cURL and PayPal IPN show up in the Apache error logs?


    Posted 12 years ago on Tuesday October 25, 2011 | Permalink
  16. I have a similar problem with one transaction (the last one).

    All previous payments in PayPal triggered the user registration on our website and generated the notification email, etc., all fine.

    However, this last payment still appears as "Processing" on the form's entry list, and yet the IPN History shows that the IPN was sent. We got the payment confirmation email that PayPal generates, and the money has been credited to our account in PayPal.

    I went back to the IPN History and told PayPal to resend the IPN, which it did, but the Gravity Form (a member registration form) still shows in its entry list that this member's payment is still "Processing."

    As I said, we didn't have this problem before, so I can't see why it would be in our case this cURL issue that is discussed in the other case above.

    Could someone help? Thanks.

    Posted 12 years ago on Tuesday November 15, 2011 | Permalink
  17. @kinohistoria If this issue is isolated to only this transaction then it's not going to be a cURL issue, it could be some sort of data issue either with the entry or on the PayPal end. The IPN may not be matching up with the entry so the entry isn't being updated.

    We can look into this if you would like us to, however it will require access to both your site and your PayPal account in order for us to debug this specific transaction. Let me know what you want to do, you can email me directly at

    Posted 12 years ago on Wednesday November 16, 2011 | Permalink
  18. Thanks, Carl. I will write you with the information you requested later today.

    Posted 12 years ago on Thursday November 17, 2011 | Permalink
  19. Carl, I sent you two emails on Friday with the information you requested. Is there any chance you could help me with this today? I'm being pressed to come up with a solution by the member who made the payment.


    Posted 12 years ago on Tuesday November 22, 2011 | Permalink
  20. Carl, I just emailed you again. I need your help very urgently. The problem was never addressed here nor through email back in November, and it has resurfaced again.

    Posted 12 years ago on Tuesday January 10, 2012 | Permalink
  21. Hi Kinohistoria,

    Can this issue be consistently reproduced? Any common threads between the issue the latest issue and the previous issue? Feel free to go ahead and send me the following and I will take a look:

    1 - WP login
    2 - FTP access
    3 - PayPal login

    Posted 12 years ago on Tuesday January 10, 2012 | Permalink
  22. pingbat

    The PayPal integration is not working at all for me.

    What if the IPN History does not have any data?

    Does the GF-PayPaypal integration require SSL?

    Using production, primary PayPal email, and all other settings seem to be set correctly (logical - per this page and this page and this page

    IPN is enabled in PayPal. Using

    Form is on a sub-page

    The GF form does send an email to admin (me) but does not forward to PayPal for payment. (PayPal Condition is enabled on GF-Paypal integration settings.) Also, the amount to be charged is either not included in the web form email (post submit) or it is 2x the intended amount. Perhaps a separate issue.

    Hosting at MediaTemple on (gs) service. Using Headway 2.0.13 theme for WordPress. All other GF forms that are not integrated with PayPal work fine. I have the GF Developer license.

    PHP Version 5.3.8
    MySQL Version 5.1.55
    WordPress Version 3.3.1
    Gravity Forms Version

    Posted 12 years ago on Thursday January 26, 2012 | Permalink
  23. pingbat

    I think I solved my issue:

    * Yes, it requires your site uses SSL
    * On the PayPal settings within GF, uncheck the last PayPal Conditions setting.

    I have not proven this to be correct, but am in the process of testing. Feedback welcome.

    Posted 12 years ago on Friday January 27, 2012 | Permalink