PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

PayPal Pro Payment Error: 10501

  1. straitline
    Member

    I get the stock error:
    "There was an error processing your request. Your credit card was not charged. Please try again."

    Which provides error #10501

    I've read these topics, but they seem to relate to the PayPal Sandbox. I am using all of the live settings and still getting the error.

    http://www.gravityhelp.com/forums/topic/paypal-pro-wont-pass-over-credit-card-info
    http://www.gravityhelp.com/forums/topic/paypal-pro-error

    "Occurs when the billing agreement is disabled or inactive. "

    Does anyone have a fix for this?

    Posted 7 years ago on Wednesday September 19, 2012 | Permalink
  2. straitline
    Member

    Also, I scrapped and renewed the API credentials to see if that was the issue, but no luck.

    Posted 7 years ago on Wednesday September 19, 2012 | Permalink
  3. Does PayPal Payments Pro show up on your "Get Started" screen, or is just the virtual terminal listed? Sounds like PayPal thinks you're trying to use PayPal Payments Pro but the account does not support it.

    Posted 7 years ago on Wednesday September 19, 2012 | Permalink
  4. straitline
    Member

    If you are speaking of the "Welcome" screen, there is nothing listed about PayPal payments Pro there. The client, thinks he is signed up for Pro and has apparently been paying for it.

    The account seems to have the pro options, I didn't think that you could obtain the API credentials without being pro...

    I am not sure if there is a technical part of the account setup that hasn't been completed.

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  5. I just logged into a PayPal account with PayPal Pro, and I found this on the My Account > Profile tab (where it lists PayPal Pro): http://i.minus.com/ib03A27bVCIZir.png - is the client's configuration the same?

    It sounds to me like PayPal is not set up correctly. I suggest having the client contact PayPal support and asking them if the account is set up correctly and what the reason for the error code 10501 is.

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  6. straitline
    Member

    Thanks for the help on this, it looks like the account isn't set up properly. I will let you know how it turns out.

    Posted 7 years ago on Tuesday September 25, 2012 | Permalink
  7. Is this a new account by chance? If so, the issue is due to the fact that PayPal recently changed the API for new accounts and they are no longer supporting PayPal Pro for new customers, only older/already signed up customers. We will be rewriting the PayPal Pro Add-On to support the new API.

    Posted 7 years ago on Tuesday September 25, 2012 | Permalink
  8. straitline
    Member

    OK, so a long phone call to PayPal by the client solved the problem.
    Thanks for your help!

    Posted 7 years ago on Tuesday September 25, 2012 | Permalink

This topic has been resolved and has been closed to new replies.