PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

plugin conflict

  1. i hav just activated a plugin called Your Responder and when signing up to a newsletter the thank you page shows a gravity forms error:

    Warning: Invalid argument supplied for foreach() in /home/blah/public_html/wp-content/plugins/gravityforms/form_display.php on line 478

    any way to fix this?

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  2. I didn't find one called "Your Responder" in my search at the repository. Can you include a URL to the plugin so we can check it out?

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  3. the plugin is from newmedias.co.uk i purchased the members plugin and got the your responder as well. let me know if i can help in any way.

    the your responder plugin does use short codes could that be where it is causing the error?

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  4. Okay, thanks.

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  5. Could you send us a link to the form so that I can take a look at the error?

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  6. on my own website thefunkhouse.co.uk you have to sign up to the newsletter then click the link in the email to confirm you want to sign up then the thank you page you get has the error on it as above. there is no form on the page

    i am just testing this at the moment so i did turn off the newsletter form widget but ive activated so you can give it a go if you wish.

    Posted 12 years ago on Sunday December 6, 2009 | Permalink
  7. Thanks slee. I will take a look at it

    Posted 12 years ago on Wednesday December 9, 2009 | Permalink
  8. hi alex i had to disable it as i had the error on the site and it didn't look too professional. i am not sure if it is a problem with the gravity plugin or the your responder plugin i have contacted them as well to see if they can help.

    i am also getting a headers already called form the YR plugin so it maybe linked.

    Posted 12 years ago on Wednesday December 9, 2009 | Permalink
  9. slee,
    The error might be caused by another plugin, but it is coming from the Gravity Forms plugin, so we should be able to fix it. I will keep an eye on it for the next release.
    If this is an urgent issue for you, i can send you an updated file to correct the issue.
    Please make sure you are on 1.3.7 and then let me know and I will send you that update.

    Posted 12 years ago on Wednesday December 9, 2009 | Permalink
  10. slee,
    I have an update for you. Just let me know where to send it to.

    Posted 12 years ago on Thursday December 10, 2009 | Permalink
  11. Hi Alex yes i am on 1.3.7 and could you send it to lee (at) thefunkhouse.co.uk

    thanks

    Posted 12 years ago on Thursday December 10, 2009 | Permalink
  12. on another website i am not getting this: Warning: Invalid argument supplied for foreach() in /home/blah/public_html/ecs/wp-content/plugins/gravityforms/form_display.php on line 478

    this happens on the login screen which i am using Themed Login and Register plugin

    Posted 12 years ago on Friday December 11, 2009 | Permalink
  13. Which plugin is this? Do you know where it can be downloaded? Doing a search on the repository turns up a variety of plugins and we'd need to know exactly which plugin you are using so that we can try it on our end.

    Posted 12 years ago on Friday December 11, 2009 | Permalink
  14. hi Carl, the details are in the posts above but Alex has fixed the issue now anyway thanks again

    Posted 12 years ago on Saturday December 12, 2009 | Permalink
  15. If anybody else is experiencing the same problem, please contact me at alex[at]rocketgenius.com and I will send you an updated version that fixes this issue.

    Posted 12 years ago on Sunday December 13, 2009 | Permalink