PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Plugin Conflicts or Plugin Combination Conflicts

  1. Nic27
    Member

    Hi,

    I have come across a rather strange set of circumstances in my WP installation. I have WP 3.2.1 installed, and I am using a Hybrid Themes Prototype child theme. I have had Gravity Forms (1.5.2.8) installed for quite some time on this setup and it has worked very well so far.

    Recently however I noticed that GF was doing something odd. I could no longer add fields to Forms. Seeing as though I had installed some new plugins I started investigating. Keep in mind GF still worked in every way, except being able to add fields to a form.

    I eventually got to the point where I have narrowed the issue down to 3 plugins:

    Google Analytics for WordPress - http://wordpress.org/extend/plugins/google-analytics-for-wordpress/
    Google XML Sitemaps - http://wordpress.org/extend/plugins/google-sitemap-generator/
    Email Login - http://wordpress.org/extend/plugins/wp-email-login/

    At present, if I activate any of those 3 plugins. I cannot add fields to any GF Form. However, with them de-activated. All works as intended.

    Now, all things said and done I have 9 active plugins (excl. the above 3) and Gravity Forms is working perfectly. 2 of those 9 are GF and the user registration add on, and one of them is Justin Tadlock's Members plugin. As far as I know, those 3 all play nicely with each other.

    As such, I am not sure what the issue is. It seems to me there must be some similarity between the 3 plugins causing the issue. However, at this stage I am not sure what that might be.

    Have you come across any such conflicts before? If so, any ideas on what exactly is causing the issue?

    Regards

    Nicholas

    Posted 10 years ago on Friday September 16, 2011 | Permalink
  2. Nic27
    Member

    Update: I have noticed a slight difference in the conflicts for the 3 plugins.

    When Google XML Sitemaps is active, I cannot add OR delete an existing form field. A dialog box is displayed saying: "Ajax error while deleting field"

    When GA for WP, or WP Email Login is active, I am able to delete existing fields, but not able to add them.

    No messages are displayed when trying to add fields.

    Posted 10 years ago on Friday September 16, 2011 | Permalink
  3. This doesn't sound like a plugin conflict, it sounds like a memory issue.

    It presents itself when you have a certain combination of plugins activated because plugins each use memory and if you deactivate a plugin it free's up memory and if you activate a plugin it then uses memory. This sometimes gets confused for a plugin conflicts when it's actually a server resource issue.

    You need to increase your available PHP memory. Here is a tutorial on how to do this:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    You may need to work with your web host on this.

    Posted 10 years ago on Friday September 16, 2011 | Permalink
  4. Nic27
    Member

    Hi Carl,

    Thank you very much for the response. I will give this a go and report back on it. I do need my host to do this so I have put in a request ticket. Will update this thread once I have checked it out.

    Posted 10 years ago on Tuesday September 20, 2011 | Permalink
  5. Nic27
    Member

    Hi Carl,

    You were right. I have activated those plugins again and they are now working correctly with Gravity Forms again.

    Thank you!

    Posted 10 years ago on Wednesday September 21, 2011 | Permalink

This topic has been resolved and has been closed to new replies.