PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Positioning of form elements

  1. I built a site here: http://wpboxx.com/newredo/coaching/. On that page there's a form in the sidebar, a form beneath the content and a form in the footer.

    The submit button on the form in the footer is positioned where I want it, and the font is correct, but if you look at the about page (http://wpboxx.com/newredo/about/), the button is very slightly different. The font size is larger and the button position is slightly higher. This problem is only happening on this page (it does use a different page template from the other pages).

    If I remove the form from beneath the content on the /about page, the problem fixes itself. I suspect this is just a stupid HTML/CSS issue I've created, but I can't find it and the client won't sign off until I do.

    Could someone take a look and tell me if I'm missing something obvious?

    Thanks,

    Posted 10 years ago on Friday November 4, 2011 | Permalink
  2. Hey Dave,

    Looks like on the page that has the multiple forms this style is being called in and using:

    [css]
    .gform_wrapper .gform_footer input.button, .gform_wrapper .gform_footer input[type="submit"] {
        font-size: 1em;
    }

    So I'd say you have a couple of options. On the form where you are just using it in the footer you can enqueue the gravity forms css and scripts (since it looks like they are not coming in from forms.css or update your style.css file to include the font size.

    You can check out the enqueue information here:

    http://www.gravityhelp.com/documentation/page/Embedding_A_Form

    Let me know if this helps!

    Posted 10 years ago on Friday November 4, 2011 | Permalink
  3. Thanks Rob, I figured I was doing something wrong. Enqueueing makes a whole bunch of sense, and I'm certain it'll fix the problem. Thanks for the quick response!

    Posted 10 years ago on Friday November 4, 2011 | Permalink
  4. No problem, glad to help!

    Posted 10 years ago on Friday November 4, 2011 | Permalink

This topic has been resolved and has been closed to new replies.