PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Post Field File Uploads not showing in Media Library

  1. I've created a form with Post Fields that takes an image upload, but it's not getting uploaded to the proper folder and not appearing in the Media Library.
    I've redirected the file upload path:

    add_filter("gform_upload_path", "change_upload_path", 10, 2);
    function change_upload_path($path_info, $form_id){
       // debug for absolute path
       //$path = getcwd();
       //echo "This Is Your Absolute Path: ";
       //echo $path;
    
       $path_info["path"] = " /home2/domain/public_html/wp-content/uploads/";
       $path_info["url"] = "http://www.domain.com/wp-content/uploads/";
       return $path_info;
    }

    The receiving folder has 777 permissions and I've disabled month/day sorting of uploads. I'm not sure what else could be wrong.

    Posted 6 years ago on Wednesday September 5, 2012 | Permalink
  2. David Peralty
    Administrator

    Where are the files being uploaded to if not to the wp-content/uploads folder?

    Posted 6 years ago on Wednesday September 5, 2012 | Permalink
  3. With the above code in place, they don't seem to get uploaded at all.

    Posted 6 years ago on Thursday September 6, 2012 | Permalink
  4. If you remove that code, do they make it to the wp-content/uploads/year/month/ directory?

    Have you changed the media upload directory and URL in the wp-admin settings? ( http://domain.com/wp-admin/options-media.php ) You don't have to and I'm not suggesting you do, I am just wondering if you have anything entered there now.

    Posted 6 years ago on Thursday September 6, 2012 | Permalink
  5. The upload URL is still blank. I haven't changed that in this installation.

    Also, if I remove the code above, it puts the upload in the standard uploads/gravity-forms/$formid/... folder. It just doesn't make it into my Gallery there.

    Posted 6 years ago on Thursday September 6, 2012 | Permalink
  6. Is there really a space before the /home on this line in your functions.php:

    [php]
    $path_info["path"] = " /home2/domain/public_html/wp-content/uploads/";

    If there is, that will cause a problem for you.

    Posted 6 years ago on Friday September 7, 2012 | Permalink