PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

problem with passing query string info

  1. I'm using a form to pass a couple of values to another form on submission. This should work without problems using the "Pass Data via Query String" on redirect after form submission.
    My form submits correctly, but the query string seems to be incomplete.. what should be /?mail=test@test.com becomes /?mail=testtest.com. Other values I tested were affected also, spaces are removed for example..

    I'm running GF 1.4.5 on WordPress 3.1-RC4, PHP 5.3.4
    Can't really show the site to the public but could give access to some people if it helps..

    any thoughts on this are appreciated..

    Posted 8 years ago on Thursday February 10, 2011 | Permalink
  2. I'm unable to recreate this issue. By default Gravity Forms escapes the query string values, which is what it should do to insure browsers don't cut off the query string. When I configure a form to pass the email in the query string the query string output in the address bar looks like this:

    ?email=test%40test.com

    The %40 is the @ escaped so it is query string friendly. It appears this is being stripped out for some reason on your site, i'm not sure what would cause this. It's possibly a server or PHP setting.

    Can you send us a WordPress admin login via our Contact Us form so we can take a look at your form setup and see it happen firsthand?

    Posted 8 years ago on Thursday February 10, 2011 | Permalink
  3. Thanks Carl,

    I think I've solved it myself, from the Apache logs it became clear some 301 redirect was happening, the initial passing of data was OK but after the 301 the values were not complete anymore. After fixing the issue with the redirect all works fine again. thanks again

    Posted 8 years ago on Thursday February 10, 2011 | Permalink

This topic has been resolved and has been closed to new replies.