PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Problem With Too Much Padding

  1. Hi, I am trying to make a contact form in the sidebar but there is too much issue with spacing. Here are the screenshots of the issue that I am having:

    http://screencast.com/t/JbnIaFng << this is how the form looks inside the highlight box...

    Just to make sure that it was not some issue with the CSS of the highligh box I placing this form How it looks if I simply place it without any outer CSS box:

    http://screencast.com/t/tIb7QU2cWcpU << still having the problem

    How it should look like: http://screencast.com/t/u0ZJNhkzao6

    Here is the URL of the form which is giving me issues: http://searchrankagency.com/content/

    Looking forward to see if it could be fixed.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  2. This is a themeforest theme and that theme uses something like the [raw] shortcode. The addition of that function and corresponding shortcode causes all shortcodes to be processed differently by WordPress. This adds extra markup to the Gravity Forms shortcode output. Please see these related discussions: http://www.gravityhelp.com/forums/tags/raw

    You should remove the function which provides the raw shortcode from your theme. You will see that the extra markup is removed from the Gravity Forms output and all the extra space will be gone.

    To further make your form look like the example you posted, you will want to use the "left aligned" label placement, rather than top. It's on the "Form Settings" tab in the form editor called "Label Placement". Top Aligned is the default.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  3. The only search results I found in shortcodes file were:

    /* Matches the contents and the open and closing tags */
    $pattern_full = '{(\[raw\].*?\[/raw\])}is';

    /* Matches just the contents */
    $pattern_contents = '{\[raw\](.*?)\[/raw\]}is';

    Is this what you are recommending that I delete?

    Though I just played with using that shortcode for fun and it seemed to make the spacing go away. I am not sure what else it might break..

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  4. In any case, removing that breaks the theme:

    Warning: preg_split() [function.preg-split]: Empty regular expression in /usr/www/users/prosra/wp-content/themes/elogix/framework/functions/shortcodes.php on line 775

    Warning: Invalid argument supplied for foreach() in /usr/www/users/prosra/wp-content/themes/elogix/framework/functions/shortcodes.php on line 778

    :((

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  5. You can wrap the Gravity Forms shortcode in the [raw] shortcode, but I was not sure how you could accomplish that in the form widget. If you read the related topics I posts (anything tagged raw) you will see discussion of a quick workaround (wrap the Gravity Forms shortcode in the [raw] shortcode) and a permanent solution (removing the function altogether.)

    The errors you are getting are because you removed the function incompletely or incorrectly. Remove the function completely and correctly and check the syntax of the file and you'll be fine.

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  6. Okay so if there is no known conflict with the raw shortcode, then it works fine. :) Thanks!!

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink

This topic has been resolved and has been closed to new replies.