PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Problem with uplaoding many images

  1. Hi,

    We have a seven page form with a lot of images (over 20). In the submissions of this form the last 5-6 images are not showing up in the entries.

    We have tried deleting and re-adding these image fields, tried duplicating fields which work but nothing seems to be helping.

    Here is our form:
    http://www.videoagent.net/order-a-property-video/

    Any ideas?

    Posted 7 years ago on Friday June 22, 2012 | Permalink
  2. Awaiting an answer...What is the typical support turnaround time?

    Posted 7 years ago on Friday June 22, 2012 | Permalink
  3. David Peralty
    Administrator

    It is likely that things are potentially timing out during the upload. Can I have you look into the following on your server for both PHP and WordPress:
    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    Try seeing about getting 256MB of memory allocated to both.

    Is it always the same images not working? Are you using file or image upload fields?

    Posted 7 years ago on Friday June 22, 2012 | Permalink
  4. 1. I already set the memory limit to 64mb which is way over the size of the images.

    2. The same problem happens with the later fields even if i upload nothing in the rest of that form just an image in that field.

    3. I've tried different images - the problem persists in the last few fields

    4. Using image upload fields

    Posted 7 years ago on Monday June 25, 2012 | Permalink
  5. David Peralty
    Administrator

    Can you e-mail me an XML export of your form? peralty@rocketgenius.com. Please make sure you include a link to this thread.

    Posted 7 years ago on Monday June 25, 2012 | Permalink
  6. pg
    Member

    Similar issues. 25 image upload fields, only first 18 are going through. Total combined size of images being uploaded is around 3mb. Each image is a .jpg at around 100kb.

    Posted 6 years ago on Friday October 5, 2012 | Permalink
  7. It may not be a memory limitation but a script timeout. Can you post a link to your php info please so we can see what sort of limitations exist on your server? Only 18 images are going through because of some sort of server limitation, not a limitation in Gravity Forms.

    Posted 6 years ago on Friday October 5, 2012 | Permalink
  8. pg
    Member

    Thanks Chris. I looked at the phpinfo.php file on the server it says:
    max_execution_time 30
    *max_file_uploads 20
    max_input_time 60
    memory_limit 32M
    upload_max_filesize 50M
    post_max_size 8M

    So I imagine "max_file_uploads" is causing the issue. How to get that limit increased? Am not certain I have control over the php.ini file. Would it work to just add that file to the root directory of the site?

    I didn't want to post the link as it's to a client site.

    Posted 6 years ago on Tuesday October 9, 2012 | Permalink
  9. pg
    Member

    My issue of not being able to upload 25 images has been solved. Thanks Chris for leading me in the right direction by uploading and referencing the settings with a phpinfo.php file ( http://php.net/manual/en/function.phpinfo.php ).

    To achieve being able to upload more files than the server specified, I did the following:
    1. Created a file called called "php.ini"
    2. In that file I put "max_file_uploads = 28"
    3. Uploaded to the root directory of the site being worked on

    Originally it was set to = 20 and I had 25 image upload fields in my form.

    Different servers will most likely support different ways of accomplishing this (.htaccess file, main host changing setting on their end), but uploading a site specific php.ini file worked in my case.

    Posted 6 years ago on Tuesday October 9, 2012 | Permalink
  10. Glad you were able to resolve that. Thank you for posting your solution here.

    Posted 6 years ago on Wednesday October 10, 2012 | Permalink

This topic has been resolved and has been closed to new replies.