PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Problems with Javascript and Jquery

  1. jhayes4

    First of all i think you've built an awesome plug-in!

    but, I'm having a problem similar to what other people have posted - that the gravity forms are not editable once i create them. (the little "edit" button in the upper right hand corner does not work ). But if i add a new field then that new field is editable, but none of the previously created fields are.

    to troubleshoot i've deactivated all of my plug-ins, including gravity forms - then reactivated only gravity forms and i still have the same issue.

    i then searched my page for jquery on my home page and on single post pages and found no references oince all my plugins are turned off

    i'm using wordpress 2.8.4
    i've tried on both Safari and Firefox browsers for the mac and have double checked to make sure that javascript is active
    i'm using Arthemia Premium Theme.
    website is

    any thoughts?

    Posted 14 years ago on Sunday October 25, 2009 | Permalink
  2. Hello Johnny,

    Have you tried switching the theme to Kubrick to see what happens? Themes can cause conflicts just like plugins can cause conflicts.

    If that doesn't work, what you will need to do is use the Contact Us form and send us a login for that WordPress site so we can see that problem happening and debug it. If we have access to your WordPress admin to see the issue, we can figure out why it is happening.


    Posted 14 years ago on Sunday October 25, 2009 | Permalink
  3. jhayes4

    Thanks for your tips Carl, we removed jquery 1.2.6 calls from the theme, then everything with gravity forms seemed to work fine.

    So i started making a new form and the javascript worked fine, but then when i came back a few hours later i got this message "Oops! We could not locate your form." - the form is still there - it's still named what i named it, but when i click to edit the form all fields have been deleted and replaced with the generic "Untitled Form
    We would love to hear from you! Please fill out this form and we will get in touch with you shortly." at the top.

    this has now happened to me twice and i'm hesitant to spend time making new forms if it's just going to get deleted again.

    is there any known bug where all the fields get wiped out, yet the name of the form stays active?

    Thanks very much for your advice on this!

    Posted 14 years ago on Wednesday October 28, 2009 | Permalink
  4. No, there are no known bugs that I am aware of that cause this... however we have encountered (again) plugin conflicts that have caused issues with saving forms. One that comes to mind is the WPML plugin. Unfortunately a lot of plugins do things they should not be doing, or load JavaScript when it isn't necessary which can cause issues.

    Try this...

    - Create a new form in Gravity Forms
    - Save the form
    - Add it to a page
    - VIew the page and see if it works
    - Go to the admin again
    - Edit the same form in Gravity Forms
    - Save the form again
    - Reload the page and see if it still works

    Let me know what happens.

    Posted 14 years ago on Wednesday October 28, 2009 | Permalink