PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Product Price and quantity - layout

  1. jfheath
    Member

    I have created a form that includes the product price and qualtity - using version 1.5.2.8. When I preview the form, the layout is as expected with Price [price] Quantity [quantity] all on one line. <span class='ginput_product_price_label'>Price:</span> <span class='ginput_product_price' id='input_2_12'>£ 250.00</span> <input type='hidden' name='input_12.2' id='ginput_base_price_2_12' class='gform_hidden' value='£ 250.00'/> <span class='ginput_quantity_label'>Quantity:</span> <input type='text' name='input_12.3' value='' id='ginput_quantity_2_12' class='ginput_quantity' size='10' tabindex='8'/>

    However, when the form is inserted in the post, there is a before Quantity and also before [quantity]

    <span class='ginput_product_price_label'>Price:</span> <span class='ginput_product_price' id='input_2_12'>£ 250.00</span><input type='hidden' name='input_12.2' id='ginput_base_price_2_12' class='gform_hidden' value='£ 250.00'/> break<span class='ginput_quantity_label'>Quantity:</span> break

    <input type='text' name='input_12.3' value='' id='ginput_quantity_2_12' class='ginput_quantity' size='10' tabindex='8'/>

    I want everything to be displayed on one line. How do I achieve this?

    Posted 10 years ago on Monday August 8, 2011 | Permalink
  2. Can you post a link to a page containing this form so we can take a look?

    Posted 10 years ago on Monday August 8, 2011 | Permalink
  3. jfheath
    Member

    You will need the following in the hosts file to see the website:
    85.233.160.70 proactivegassafety.com

    The link is http://proactivegassafety.com/open-workshops/oxy-fuel-gas-inspectors-workshop

    Posted 10 years ago on Tuesday August 9, 2011 | Permalink
  4. timbonnett
    Member

    Not sure if this will help or not but I had a similar issue with something splitting my quantity inputs onto different lines. I ended up finding this. (also copied below)

    http://wordpress.org/support/topic/auto-formatting-glitch-in-21

    Not ideal to edit a core WP file but it solved my issue.

    ----------------
    I have upgraded my blog to WordPress 2.1. With one exception, the process was fairly painless. The exception was my politics test plugin. The new version of WordPress was inserting line breaks into the questions. I had to get my fingers dirty and find out what was happening. It turned out that the auto-formatting function [wpautop() in the file ~/wp-includes/formatting.php] had been rewritten so that input XHTML tags were now treated as blocks. The fix was easy: I deleted the input keyword from the list of blocks.

    I am buggered if I know why they did it. Can someone explain?
    -----------

    Posted 10 years ago on Tuesday September 27, 2011 | Permalink
  5. @timbonnett wpautop() should NOT be getting applied to shortcode output. So it shouldn't be impacting the Gravity Form markup. If wpautop() is being applied to the shortcode output then you have a theme or plugin installed that has changed how WordPress works and is causing this issue.

    This is common with ThemeForest themes that implement a shortcode called RAW or NOFORMAT that allows you to use a shortcode to disable WordPress auto-formatting on a portion of a page or post text content.

    It's negative side effect is while it lets you not apply auto-formatting to text wrapped in the shortcode, it then applies auto formatting to ALL other shortcode output. Which causes problems like the one described above.

    So this is a theme or plugin conflict that is causing this issue. My guess it is a theme. To determine the cause you can follow the instructions here:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 10 years ago on Tuesday September 27, 2011 | Permalink

This topic has been resolved and has been closed to new replies.