PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

reCaptcha alignment

  1. Hi
    I've a small problem really but my Captcha won't line up with the other cells on my form. It keeps floating left as here: http://www.livesharetravel.com/contact/
    Can anyone assist?

    Thanks

    Posted 8 years ago on Monday November 29, 2010 | Permalink
  2. What browser are you seeing the alignment problem in?

    Posted 8 years ago on Monday November 29, 2010 | Permalink
  3. I'm using Chrome.

    Posted 8 years ago on Monday November 29, 2010 | Permalink
  4. You can try adding this to your custom.css.. should work just for Safari and Chrome

    /* saf3+, chrome1+ */
    @media screen and (-webkit-min-device-pixel-ratio:0) {
     body .gform_wrapper .left_label #recaptcha_widget_div,
    body .gform_wrapper .right_label #recaptcha_widget_div {margin-left:32%;}
    }
    Posted 8 years ago on Monday November 29, 2010 | Permalink
  5. That's worked - thanks very much!

    Posted 8 years ago on Monday November 29, 2010 | Permalink
  6. Note: I have reworked the reCaptcha CSS rules in version 1.5 to override the default reCaptcha CSS which was causing this problem. Once 1.5 is released, the rules above shouldn't be necessary.

    Posted 8 years ago on Monday December 6, 2010 | Permalink
  7. hi ive just installed the gravity forms and have the same problem - im not that tech savvy but the recaptcha is not left aligned when i put shortcode into my contacts page @ http://www.mutantspace.com/contact-our-skills-exchange/ thanks..

    Posted 8 years ago on Friday July 29, 2011 | Permalink
  8. @mutantspace, your issue is being caused by your theme. Line 892 of your theme's style.css file is setting a 91 pixel left margin on the recaptcha div.

    [css]
    #recaptcha_widget_div {
        margin-left: 91px;
        padding-bottom: 20px;
    }

    If you disable the margin property there, you'll see that the element aligns properly.

    screenshot: http://bit.ly/q6fJtn

    You can add this to the end of your theme stylesheet and it should override the offending style.

    [css]
    body .gform_wrapper #recaptcha_widget_div {
        margin: 10px 0 0 0;
    }

    screenshot: http://bit.ly/o7PoM0

    Posted 8 years ago on Friday July 29, 2011 | Permalink
  9. man, that was fast thanks alot much appreciated

    Posted 8 years ago on Friday July 29, 2011 | Permalink