PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Recaptcha blocked on HTTPS page in IE

  1. Our recaptcha elements on our form pages have started to be blocked on pages in IE. Our forms are HTTPS, and IE blocks the recaptchas because they aren't secure content. We have seen a significant drop in volume from these forms in the past few months, and now I'm guessing this is the reason.

    Here are the pages in question:
    https://vostn.com/referral/
    https://vostn.com/new-patient-form/
    https://vostn.com/medication-refill-form/

    How can this be fixed? Do we even really need recaptchas? I put them on there because it seemed like a good way to block spammers, but how necessary are they for security?

    Thanks for your help!

    Posted 6 years ago on Friday February 22, 2013 | Permalink
  2. David Peralty
    Administrator

    I would recommend enabling honeypot on the advanced settings of the form and installing this captcha plugin and swapping out recaptcha for it. Since it won't be pulling from a third party source, it should be secure and not provide such an error.

    http://wordpress.org/extend/plugins/captcha/

    All my best!

    Posted 6 years ago on Friday February 22, 2013 | Permalink
  3. Thanks, David. I've removed the captchas for now, enabled Honeypot, and installed the captcha plugin, but I'm not sure where to go from there... I apologize for my lack of expertise! Is there a custom field I should be working with?

    Posted 6 years ago on Monday February 25, 2013 | Permalink
  4. David Peralty
    Administrator

    You should now add the Captcha field and from the field settings select Captcha from the type. All my best!

    Posted 6 years ago on Monday February 25, 2013 | Permalink
  5. I don't think I'm doing right... do you mean to add the captcha field from the list of advanced fields? I didn't see settings to select the type when I did that, and it was still rendering as unsecure content. What field should I be adding?

    Posted 6 years ago on Tuesday February 26, 2013 | Permalink