PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

ReferenceError: gf_apply_rules is not defined

  1. Hi,

    We're getting this error on our page http://www.i4es.it/descrivi-sito-web.
    Tried all possible combinations, cleaned the theme (we use Thesis 1.8.2), disabled all plugins but no luck. We already read all the thread on the support forum.

    Can you help us out?

    Thank you

    Massimo

    Posted 5 years ago on Monday January 28, 2013 | Permalink
  2. I don't see any errors on that page and the form appears to be working fine. Where do you see this error?

    However, you are including 3 incorrect versions of jQuery in that page:

    <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js?ver=1.7.1'></script>
    
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
    
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>

    WordPress 3.5.1 requires jQuery 1.8.3. Please let WordPress enqueue the correct jQuery version and get rid of these extra version, and so long as there are no other jQuery or JavaScript errors on the page, I think you will find your forms work properly.

    Also, you have a lot of invalid HTML on the page as well. Please correct the validation errors if you are able and your page will work more reliably across all browsers:

    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.i4es.it%2Fdescrivi-sito-web

    Posted 5 years ago on Tuesday January 29, 2013 | Permalink
  3. Hi,
    now we have the correct version of jQuery (1.8.3) but we're getting the same error on our page http://www.i4es.it/descrivi-sito-web.  We know we're including two versions but if we remove the second one, we get the following error... "ReferenceError: jQuery is not defined".
    Can you help us?

    Please check the website again...!

    Thank you

    Posted 5 years ago on Tuesday January 29, 2013 | Permalink
  4. I see this error now:

    Timestamp: 1/29/2013 11:10:00 AM
    Error: TypeError: $(...).on is not a function
    Source File: http://squeekpress-ws4.info/wp-content/plugins/the-events-calendar/resources/events.js?ver=3.5.1
    Line: 14

    That seems to be coming from an events calendar plugin? Have you already tried disabling plugins by following these instructions? http://rkt.gs/testing

    Posted 5 years ago on Tuesday January 29, 2013 | Permalink
  5. You also have an extra style tag in the head, and all the script links are inside of it. Look at the source of the page and see line 20: that should not be there.

    If you validate the XHTML on the page as suggested a couple replies ago, this will be easier to troubleshoot with less back and forth.

    Posted 5 years ago on Tuesday January 29, 2013 | Permalink