PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Registration Problems and 3 email attempts to contact gravity support that faile

  1. I have purchased 2 copies of gravity forms.

    One of them has been giving me problems with a message that my copy has not been registered. I have made at least 3 attempts to contact gravity customer support via their contact form/page and so far for over 1 1/2 months no response whatsoever. That is the worst customer service I have seen so far.

    How long does it take to respond to a customer who bought your product?

    How many emails before you do so?

    Posted 9 years ago on Monday August 16, 2010 | Permalink
  2. Your Contact Us requests were being directed to my spam filter. For some reason your email has been flagged. I have removed them from the spam box and have just read them.

    However, that being said email and our Contact Us form is not the appropriate method for requesting support. In the future please post requests here on the support forum and you will receive a prompt response as there are no issues that can crop up with email (such as spam filters) and the support forum is the appropriate place to request support.

    MailChimp is currently only available to Developer License holders. If you wish to upgrade we can provide you with a coupon code based on what you have already spent on the plugin. So if you purchased 2 Single Site Licenses, the discount on the Developer License would be equal to the cost of the 2 Single Site Licenses you already purchased.

    As for the message that the plugin has not been registered, this would be due to not entering the license key correctly on the Settings page of the plugin. You need to make sure the license key is entered 100% correctly with no extra spaces before or after the key... which is common when copy-n-pasting the key. Then save your settings again.

    The latest version of Gravity Forms should help combat the issue of copy-n-pasting adding extra blank spaces before or after the key.

    Posted 9 years ago on Monday August 16, 2010 | Permalink
  3. Thank you for your reply Carl. I have copied and pasted to registration code as cleanly and without any spaces as possible... If I do still have problems I will let you know.

    As per the upgrade, a month an a half ago, I wouldn't have hesitated at all because I love your plugin. However, since I am no developer and since my experience in the last 45 days or so give me no incentive to spend an extra 150$ just so I capture a couple of people per week from my contact form, unless you send me a much better offer for the upgrade I will not spend the money on it.

    Thanks!

    Posted 9 years ago on Monday August 16, 2010 | Permalink
  4. Hey Carl,

    last time I copied and pasted the codes as cleanly as possible and today I had the "register your copy" message again so it didn't seem to work at all.

    What do I do now?

    Posted 9 years ago on Saturday September 4, 2010 | Permalink
  5. Try it again, there could have been a connectivity issue with our license server. We will be migrating to a new data center sometime in the next week or so and that should solve any issues such as this. But if for any reason your server isn't any to communicate with ours, the license key may not validate. Just try again if this happens.

    Posted 9 years ago on Saturday September 4, 2010 | Permalink
  6. Hi Carl,

    It seems that now I have the registration problem not with Gravity forms plugin itself but with the Mail Chimp add on. I tried to activate it a few times - 3 times today, and the problem still persists and I still get the message that I need to "register my copy of Gravity Forms to receive access to automatic upgrades and support." Interestingly, this message doesn't show up under Gravity Forms plugin itself but under the Mail Chimp add on...

    I have purchased 2 single user licenses and one developer license so far and still have the problem.

    How do I resolve the issue permanently?!

    Thanks!

    yours,

    Nikola

    Posted 9 years ago on Tuesday January 25, 2011 | Permalink
  7. Hi Nikola, I am researching this issue and will get back with you as soon as possible. :)

    Posted 9 years ago on Wednesday January 26, 2011 | Permalink
  8. @nikola What version of Gravity Forms are you running? The public 1.4.5 release or one of the 1.5 development releases?

    This could also be due to server issues we have been experiencing. Plugins check for updates independently. So Gravity Forms may have been able to reach our license server and validate, but the Add-On may not have.

    Updates are also checked and the results cached so that it isn't constantly checking for updates. So it may be several hours before it checks for updates again, and until then if it didn't validate it would display that message until it does validate.

    We will be migrating web hosts next week to our new server which will eliminate the license key server related issues we have been experiencing. If it's related to that issue, our server migration should resolve the issue.

    Posted 9 years ago on Thursday February 3, 2011 | Permalink