PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Reply to address not set to email when using WP Mail SMTP

  1. I am trying to create a support form on my website that asks for a users email and name, then sends an email to my support mailbox that contains the from address set to the customers email address. I am having to use WP Mail SMTP to send the emails through rackspace via authenticated SMTP.

    The problem I have is despite setting the From and Reply to fields in the form notification settings to 'Email', the email is always from my support email address so I cannot easily reply. In the Wordpress / Email settings I have tried leaving the from Email blank or setting it to my support email, and no matter what I do this seems to override what is configured in the notifications setting.

    Is there anyway I can get this working?

    Thanks

    Posted 7 years ago on Wednesday December 14, 2011 | Permalink
  2. If you ask for an email address in your form, you can use that address as the "From" in your notification. Here's a screenshot: http://minus.com/mxCkMXXbT#1

    If you do not use an email field to capture the email address, I don't believe this option appears. For example, if you used a text input to grab the email without validation. That would not appear here because the form builder does not know that the field is an email field.

    Don't fill in the text input, just use a the drop down and select the user's email input from the form and the email will come from them. Some servers have a problem with that configuration, but that can be worked around, especially used authenticated external SMTP as you are.

    Posted 7 years ago on Thursday December 15, 2011 | Permalink
  3. That screenshot is exactly as I have it configured. The field on the form is called Email and was added using the Advance Fields / Email option.

    The issue seems to be that Gravity Forms is using the email used to authenticate to the auth SMTP service, rather than the one on the form.

    Posted 7 years ago on Sunday December 18, 2011 | Permalink
  4. It sounds like this is a mail server configuration issue. When you send the test from WP Mail SMTP, does it arrive correctly, with the proper From email address?

    Posted 7 years ago on Tuesday December 20, 2011 | Permalink
  5. I am having this issue as well. Everything is configured correctly, but all my form submissions from customers arrive in my inbox from me rather than them. It makes it quite difficult finding a particular submission.

    Posted 7 years ago on Monday January 2, 2012 | Permalink
  6. Can you post screenshots of how you have this configured? The admin notifications will arrive from the visitor's email if you have this configured correctly.

    Posted 7 years ago on Tuesday January 3, 2012 | Permalink
  7. here you go! http://mediavandals.com/form.png

    Posted 7 years ago on Tuesday January 3, 2012 | Permalink
  8. Looks correct. Are you using any custom functions in your theme's functions.php that would affect the notifications?

    If you can you export the form, I will install it locally and try to recreate the problem. Export the form as XML and email it to chris@rocketgenius.com

    Thanks

    Posted 7 years ago on Wednesday January 4, 2012 | Permalink
  9. I just purchased a single license of Gravity Forms, and I'm having the exact same issue.

    I've tried it with both WP Mail SMTP and with standard wordpress configuration on my server, which has worked with other form plugins in the past.

    Edit:

    I wanted to add that the issue is similar to what is described here:

    http://www.gravityhelp.com/forums/topic/administrator-reply-to-notification-issue-w-godaddy

    But, I am routing emails through to GMail, still to no avail.

    Posted 7 years ago on Monday January 9, 2012 | Permalink
  10. Justin, I replied to your email. The form worked fine for me, which means the form is OK but there is something with your host configuration causing this problem.

    Posted 7 years ago on Wednesday January 11, 2012 | Permalink
  11. Sheila, the form submission and notifications are working fine on my server. This is going to be related to your host configuration. Please contact their support to troubleshoot further. I also replied to your email. Thanks.

    Posted 7 years ago on Wednesday January 11, 2012 | Permalink
  12. andrew carbn
    Member

    Does anyone know how to get this working? I have the exact same issue. What is the work around?

    Unfortunately I use Godaddy as my hosting. There must be a setting in there to change.

    Posted 7 years ago on Sunday January 22, 2012 | Permalink
  13. We are having the same issue using Google Apps email accounts.

    After some basic testing, we've noticed that this issue only occurs when the WP Mail SMTP 'From' email address is set to be the same as the 'From' email address of Gravity Form.

    Looking forward to the fix of this.

    Thanks

    Posted 6 years ago on Thursday July 19, 2012 | Permalink
  14. I'm experiencing this issue as well. We use the Wordpress SMTP plugin to send emails through GMail. We've had no troubles receiving the email notifications, though it's when we try to reply that we see inconsistencies. We use the email wordpress@OURDOMAIN.com to send the emails from Wordpress.

    Sometimes the 'to' address in a reply has "wordpress@OURDOMAIN.com <wordpress@OURDOMAIN.com>" as the address and other times it has "name@useremail.com <wordpress@OURDOMAIN.com>" and other it has the users email in both places. It's easy enough to replace the 'to' email address with the users email, though it's an announcement that might be able to be fixed. Plus on an iPhone it's harder to replace the to address and if I'm using Gravity Forms for a client website, they'll get annoyed by this.

    Posted 6 years ago on Friday July 20, 2012 | Permalink
  15. If you have a moment, Joost de Valk has written up a really good summary of the problem, along with some suggestions, on getting more reliable email delivery. It covers Google Apps as well.

    http://yoast.com/email-reliability/

    Gravity Forms simply hands off the notification email to wp_mail() and if you're using the WP Mail SMTP plugin, that replaces wp_mail() with your SMTP server. Server config and MTA on both ends have more to do with the problem than Gravity Forms does. If you do see a problem specific to the email notification that Gravity Forms is sending, please let us know. But it most, if not all cases, the trouble with email delivery was not coming from Gravity Forms.

    Posted 6 years ago on Friday July 20, 2012 | Permalink
  16. chill986
    Member

    I'm having the same problem. HOWEVER, the reply-to email address is coming through, the from email address is not (this is for the email received by the form submitter). This is the last thing we need before going live, and it's a concern, because I'm getting userid@hostingserver.com instead of the email I have set up in the notifications, and those emails initially go to spam. Can't afford for them to be forced to spam the first time. Why would it work for the administrative emails and the "reply-to", but not the "from"? Doesn't make sense.

    Thanks for any help you can give me on this. Kinda time sensitive.

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  17. Can you share a link to your form please? Will we be able to see a notification with the From email address shown?

    The From email address is being set by your server, not Gravity Forms. Some servers don't like pretending the email is from another address. Are you using an SMTP plugin and sending email via SMTP now?

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  18. Also, please see this note from another member: http://www.gravityhelp.com/forums/topic/how-to-make-sure-your-smtp-plugin-works#post-85316

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  19. chill986
    Member

    http://66.147.240.184/~ayresadv/contact/

    I'm not using any SMTP plugin as of yet - that's my last ditch effort. Just got off the phone with Hostmonster - because it's only on one of the emails (comes across correctly to notify that a form has been submitted, but not correctly to the visitor).

    Also, one of my forms, I'm not getting ANY notification that someone has submitted a form (request a catalog - at the bottom of the home page). I"ll take a look at the other link you posted above but since I'm not using an SMTP plugin yet, not sure it will help just yet.

    Thanks for replying so quickly!

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  20. chill986
    Member

    If you need access, please provide me an email address, and I'll add you right away.

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  21. chill986
    Member

    It's odd - if I use MY email address (and I'm also the admin) MY email address shows up. However, any other email address used shows up as ayresadv@host384.hostmonster.com.

    Posted 6 years ago on Monday November 19, 2012 | Permalink
  22. There is no harm in using an SMTP plugin. Once it's configured, it will make email delivery more reliable, not just from Gravity Forms but for any email sent from your WordPress site.

    Because you are a developer license holder and this is time-sensitive, you can also opt to use our Priority Support. http://www.gravityhelp.com/priority-support/

    If you use the Priority Support form, please be sure to include a link to this topic.

    Posted 6 years ago on Monday November 19, 2012 | Permalink

This topic has been resolved and has been closed to new replies.