PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

'Required' Dropdown container not getting proper classes

  1. 'gfield_contains_required' and 'gfield_error' are not given to the element that contains required dropdown lists, making them un-style-able when they are not properly filled out.

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  2. Looks like they're working fine for me.

    screenshots: http://bit.ly/pGoerr , http://bit.ly/oTNW9W

    What version are you using and more importantly, can you post a URL to your form so we can take a look at it.

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  3. Yeah, I show them working in preview mode too, but when output on the frontend, none of the 3 dropdowns get those classes.

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  4. yeah, if it works in your preview and not in your theme then there's some kind of plugin/theme conflict going on. Have you tested the form in a different theme?

    You'll probably want to test for conflicts to see if you can narrow it down. http://rkt.gs/testing

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  5. This is a hand coded theme with nothing but one page and no special code going on, and gravity forms is the only plugin installed. Could it be that i'm using the template tag to bring in the form and not the shortcode?

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  6. Got it, it had something to do with me not declaring all of the options in the function: <?php gravity_form(1, false, false, false, '', false); ?> -- at least that's what I changed it to to fix it.

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink
  7. Yea, if you didn't pass everything to the function call that can cause problems. Glad you figured it out.

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink

This topic has been resolved and has been closed to new replies.