PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Required fields fail to populate -> Error cycle

  1. I'm having an issue with some advanced fields in my forms. Specifically the Address and the compound Name field.

    The entire website was moved, pretty much as-is from one server to another. Here are two comparison pages, the first, with the working form, the second, with the non-working form. This very same error occurs on multiple forms, but I'll use one form as a demo.

    Old site: works.
    http://magazinemci.com/sabonner-au-magazine/

    New site: busted.
    http://magazinemci.info/sabonner-au-magazine/

    What happens is that I'll enter some valid data into the forms and all Advanced (compound fields) correctly send the data. On the first site, it just goes though as it should. Error checking functions correctly when invalid data is entered.

    On the second site, the form values are passed onto WP, but the page reloads with a field required error, and display blank fields. Re-entering the data and resubmitting it only leads to a loop.

    If I remove the compound fields, and replace the Advanced Name field with two single line text fields, these newly added fields, while still being required, behave correctly.

    I cannot remove the previously created Advanced fields to re-build the form without loss of previously entered data, so my only option is to figure out how to cause the Advanced compound fields to behave correctly.

    Your thoughts and advice would be appreciated.

    Posted 10 years ago on Monday October 24, 2011 | Permalink
  2. I'm having a very similar problem with the advanced compound name field. I am suspecting it has to do with the input ids for the individual input fields but I haven't cracked it yet. I'll let you know if I figure it out. Please do the same for me.

    Posted 10 years ago on Sunday October 30, 2011 | Permalink
  3. Yep, that was it. In my case, some of the advanced compound fields had a mismatch between the field id and the input id. I exported the form as an .XML file, then edited the input ids to match the field id. Input ids should match the field id, with a decimal after signifying which input it represents.

    See here:

    <field id="15" isRequired="1" size="medium" type="name">
    				<label><![CDATA[Name]]></label>
    				<inputs>
    					<input id="15.3">
    						<label><![CDATA[First]]></label>
    					</input>
    					<input id="15.6">
    Posted 10 years ago on Sunday October 30, 2011 | Permalink
  4. Glad you worked that out. Thank you for posting the solution.

    Posted 10 years ago on Monday October 31, 2011 | Permalink

This topic has been resolved and has been closed to new replies.