PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Routing notifications

  1. LitSuppGuru
    Member

    Notifications is working fine. I have the check box checked. I have the e-mail address entered at the top and a BCC entered at the bottom. I have been receiving notifications like this for months.

    Then, when I switch to Routing, things don't work the same. I added one routing option for "chapter is Philadelphia". I noticed the BCC is being ignored. Not sure why.

    Also, once routing is turned on with one option for Philadelphia, I no longer receive notifications for any of the other chapter submissions. Is that how is it supposed to work? In order to receive all notifications with routing turned on, do I have to set up routing items for every scenario possible from that field? In this case, I would have to set up routing items for each of the other 29 chapters??

    Thanks.
    Amy

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  2. David Peralty
    Administrator

    Gravity Forms will not send an e-mail if none of the routing conditions are met. So if you want to route one for Philadelphia, but no others, then set up another routing condition that says "is not Philadelphia".

    I am not sure why BCC would be ignored. Are you trying to send to multiple e-mail addresses in each field?

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  3. LitSuppGuru
    Member

    Thanks David. My database logic said the same thing -- why not create a routing item for everything else, as in "chapter does not contain Philadelphia". However, with the options presented to me, I didn't see how to accomplish that. Can you point me in the right direction?

    At one point, I did have two e-mail addresses in the BCC with a comma delimiter and it wasn't sending to either (when routing is turned on). It works without routing turned on.

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  4. David Peralty
    Administrator

    The dropdown allows you to select other values including "is not"
    http://upranked.com/emailrouting.jpg

    If you do routing, can you try it with one e-mail in the BCC and see if it works? We have been experiencing e-mail issues in the more recent versions of WordPress due to some changes made to their wp-mail.php function.

    Posted 7 years ago on Thursday June 28, 2012 | Permalink
  5. LitSuppGuru
    Member

    Okay, I will try that. Thanks David.

    Posted 7 years ago on Friday June 29, 2012 | Permalink