PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Safari 5.1 and Gravity Drop down menus

  1. jimmywhitetrix
    Member

    Since upgrading to Safari 5.1 none of my drop down menus work in my gravity forms.

    Please see - http://web.santamaria.wa.edu.au/index.php/college-community/old-girls-association/membership

    I am using Wordpress 3.1.2 - and Gravity Forms - Version 1.5.2.2

    I would prefer not to upgrade my Wordpress version - any help appreciated

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  2. Well, I tested in Safari 5.1 and couldn't replicate any problems with the selects/drop-down fields.

    screenshot: http://bit.ly/n4uVVh

    screenshot: http://bit.ly/pgsxni

    Have you tried clearing your browser cache?

    Also, there is a newer version of Gravity Forms available. It's always good to run the latest versions to make sure you have the most current updates, bug fixes and enhancements. You should be able to auto-update to the newest version directly from your plugins page, or you can download the latest version from the plugin downloads page linked in the sidebar and manually install it if you prefer.

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  3. Hi to every body, same problem
    I tested
    gravity form 1.5.2.8
    with Safari 5.1 on Mac drop down menus doesn't work
    with Safari 5.1 on PC drop down menus work fine

    gravity form 1.5.1.1
    with Safari 5.1 on Mac drop down menus work fine
    with Safari 5.1 on PC drop down menus work fine

    well maybe there is some inconpatibility between the latest vesion (gravity form 1.5.2.8) and Safari 5.1 on Mac.

    Let us know Thanks
    Marcello.

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  4. Marcello. I've tried multiple sites using Safari 5.1 on the Mac platform and don't have any problems. Nothing changed in Gravity Forms that should affect the default behavior of the drop-down (select) controls.

    If you're using some kind of jQuery script to replace select boxes/drop-down menus then there could be a problem depending on which version of WordPress you're using. WordPress recently changed which version of jQuery is loaded and that could have some bearing if you're using one of these form scripts.

    Can you post a URL to your form page so we can test it out?

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  5. Hi Kevin
    I'm currently using
    jquery1.6.1 on Wordpress 3.2.1
    Here you can find the form
    http://www.aibi.it/sostegno-a-distanza/pagina-di-esempio/
    Let me know Thanks
    Marcello.

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  6. @cellos This is a markup issue or a javascript issue most likely with the theme, and not with Gravity Forms. This isn't default behavior and the issue has only been reported in this thread.

    You will have to test for theme and plugin conflicts by following these instructions:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    My guess is it's a theme issue, but you'll want to test for theme AND plugin conflicts.

    Posted 8 years ago on Wednesday July 27, 2011 | Permalink
  7. jimmywhitetrix
    Member

    I am having a lot of trouble correcting this behaviour. I tested cellos' website and experienced the same problems which I have been having. The drop down menus cause the browser to refresh the page.

    @Kevin Flahaut - are you using Lion 10.7? I have tested my forms across 4 different Macs on Safari 5.1, they are all using Snow Leopard and all have the same problem.

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  8. @jimmywhitetrix,

    I am using Lion on my primary machine, but have tested in 5.1 on my other machine and still wasn't able to recreate the issue. The select/drop-down fields are just normal form controls output by the plugin so there shouldn't be any reason they wouldn't work normally in the browser.

    Do they work in the form preview page properly for you?

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  9. madamelolo
    Member

    Hi I have the exact same problem, dropdown menu doesnt work on safari 5.1 :(

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  10. Checked again on a few different Gravity Forms and I still can't recreate any issues with the select/drop down fields. Check out this test - one is the Gravity Forms demo running current version of Gravity Forms (1.5.2.8) with WordPress 3.2.1 and the other is the form @cellos linked to above.

    http://screencast.com/t/AXh6ZqLTpFc

    I'll do some more testing, but right now I'm not sure what to tell you since I can't seem to replicate any problems.

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  11. madamelolo
    Member

    Hi Kevin I am under the same configuration as Jimmy , WordPress 3.1.2 and can not upgrade right now to 3.2.1.....

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  12. madamelolo
    Member

    And here is a link to the form http://dev.juicyagency.com/en/news/capitalesmode/le-grand-defile/#gform_wrapper_4 any help would be much much appreciated

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  13. @madamelolo, do your select fields work properly in the form preview? I'm betting they do.

    I copied your form page to my development area and disabled the link to your theme stylesheet. When I did, your drop-downs functioned properly. You can see my test here.

    http://screencast.com/t/7xLiiFpoHRx

    There's something in your theme CSS that's interfering with the normal form element functionality. I don't know what just yet, but you should contact your theme provider for some guidance on that. It's not really a Gravity Forms issue in your case.

    If I find out anything more to help you out, I'll gladly post it here.

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  14. madamelolo
    Member

    Select field and check boxes work fine indeed, I will try out disbling styleing on the dropdown and check with theme and will keep you updated.
    Thanks !

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  15. Sounds good. Thanks.

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  16. madamelolo
    Member

    Worked !!! Came from a line in my css file .gform_wrapper select , I just put it as comment and now it seems to be back to normal. Thanks Kevin !

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  17. @madamelolo, sounds great. Thanks for the update.

    Posted 8 years ago on Thursday July 28, 2011 | Permalink
  18. jimmywhitetrix
    Member

    "Came from a line in my css file .gform_wrapper select , I just put it as comment and now it seems to be back to normal. Thanks Kevin !"

    Would you be able to expand on this fix a little more for me please?
    I cannot locate ".gform_wrapper" in my style.css file. (but then I am a newbie). Once located how do I put it as a comment?

    Thank you for your help

    Posted 8 years ago on Friday July 29, 2011 | Permalink
  19. @jimmywhitetrix, the other user already had some custom Gravity Forms styles added to their theme that were the source of the issue. If you haven't already added custom rules for your forms, it's doubtful that you'll find the ".gform_wrapper" class defined in your theme stylesheet.

    Posted 8 years ago on Friday July 29, 2011 | Permalink
  20. jimmywhitetrix
    Member

    Hi again,

    after a few weeks of trying different things I worked out that this is a font issue. Hence the reason that it worked on a few computers on not others. (depending if the font was installed I guess)

    The offending font family was Droid Sans (when I remove the entry form my style sheet the forms behave perfectly) -

    body { line-height: 18px; font-family: 'Droid Sans', Arial, sans-serif; font-size: 12px; color: #8c8b8b; text-shadow: 1px 1px 1px #ffffff; background: #131a26 url(images/footer-bottom-bg.png) repeat-x; }

    @Kevinflhaut - Would you mind recommending another font-family that I may use? I have yet to remove this 'Droid Sans' permanently as I feel it should be replaced with something stable.

    Posted 8 years ago on Tuesday August 16, 2011 | Permalink
  21. maisiam
    Member

    I have the same problem only if the Drop Down field is required.
    If no one value is null the problem occurs immediately, otherwise (inserting a null value in the list) the field works only if some choice is made, whereas after the error is showed in red if you make some choice you're redirected to the home page and disconnected from admin panel.
    My platform is Safari 5.1, Mac OS X 10.7.1, Wordpress 3.2.1.

    Posted 7 years ago on Friday September 23, 2011 | Permalink
  22. maisiam, can you post a link to your form so we can test it out? Thank you.

    Posted 7 years ago on Saturday September 24, 2011 | Permalink
  23. maisiam
    Member

    I resolved the issue removing the line
    .gform_wrapper .top_label .gfield_error select {border:1px solid #790000}
    in the file forms.css
    located in /wp-content/plugins/gravityforms/css/

    I can't post a link visible to everybody because is a testing page. I can send it to you privately.

    Posted 7 years ago on Saturday September 24, 2011 | Permalink
  24. HI Guys I resolved the issue setting in Forms-->>Settings-->>Output CSS (?)-->NO

    Bye Bye Thanks for the support .-)

    http://www.frog-me.com

    Posted 7 years ago on Tuesday September 27, 2011 | Permalink

This topic has been resolved and has been closed to new replies.