PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Saving Admin Label or Parameter Name fails when using __

  1. I am trying to use the salesforce integration plugin with Gravity Forms to map some custom fields. This requires setting the Admin Label or the Parameter Name of a field to the API custom field name provided by Salesforce. This name is in the format (for example) County__c ..

    When I enter the name into either field and save the form, my entry disappears and is not saved. If I remove one underscore the entry is saved. So for some reason the double underscore is triggering some sort of form sanitize filter. Is this by design? Is there any work around?

    Thanks!

    Note: this is independent of the Salesforce addon, I realize this is a 3rd party piece, but the issue is not related to the addon, but this is required to make the addon work properly.

    Posted 7 years ago on Tuesday November 15, 2011 | Permalink
  2. Actually - in thinking abouut that last statement I realized i hadn't tried it with the salesforce plugin disabled. Oddly enough this fixed the issue in most cases-

    one exception was Name_of_second_registrant__c .. this one did not save, while shorter versions Begin_Farming__c - for example saved. And then upon reactivating the salesforce plugin the entries remained. Strange!

    Any ideas or help?

    Posted 7 years ago on Tuesday November 15, 2011 | Permalink
  3. What SalesForce plugin are you referring to?

    Posted 7 years ago on Tuesday November 15, 2011 | Permalink
  4. Sorry -

    http://wordpress.org/extend/plugins/gravity-forms-salesforce/

    Posted 7 years ago on Wednesday November 16, 2011 | Permalink
  5. Did anyone ever get an answer to this issue. I have the same issue where the labels are not saving.
    Any ideas how to make the labels save?

    Thanks

    Posted 7 years ago on Tuesday March 6, 2012 | Permalink