PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Selecting Drop Down items in IE9 not working correctly

  1. I'm testing a site prior to launch, and see that when in IE 9 the drop down fields are not working as they should. When the user tries to select an item from the drop down list, the form will most often put a blue box in the input area and hide the dropdown list making it impossible to select from the list. This is not always the case in the first drop down I have in the form, but is almost always the case in the second drop down.

    Here's the URL: http://whub34.webhostinghub.com/~videoh6/brucetesting.com/about/how-can-we-help/

    I look forward to your help with this.

    Thanks very much,
    Bruce

    Posted 6 years ago on Monday April 22, 2013 | Permalink
  2. Still looking for help. I've deactivated all plugins, and removed all the javascript that I added to my theme, but it is still either difficult or impossible to select from the drop-down in Internet Explorer 9.
    I'd greatly appreciate a response, as this is delaying launch and the client is not happy.
    Thanks,
    Bruce

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  3. Bruce, what happens when you preview the form from within the form builder preview window in IE9?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  4. Thanks for the reply, Rob.

    The drop down works as it should from within the form builder in IE9. Does this mean the problem is with the theme, or could it be something else?
    Thanks,
    Bruce

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  5. Bruce,

    When it works in the preview window this does usually mean it's either a theme or plugin causing the conflict. It could be related to JS or CSS, I see you said you disabled some JS, but have you gone through the CSS that's getting output on the page yet?

    Posted 6 years ago on Monday April 29, 2013 | Permalink
  6. I went ahead and took out all custom CSS, all custom Javascript, all custom header scripts, and disabled all plugins except for GF. I am unfortunately still having this same dropdown problem in IE9.

    I also tested GF drop downs on a form that I have on another site, with the same theme. These work in IE9, so it is not the theme.

    I am completely mystified (and frustrated). Any other thoughts?

    Thanks,
    Bruce

    Posted 6 years ago on Monday April 29, 2013 | Permalink