PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Send from field on notification setting page doesnt work

  1. Luke
    Member

    I'd like to have my form to send notification emails to my email box. The send from field of each email should be different from wordpress default email. I set up the 'from email' field on the notification page. However, it did not work.

    Posted 7 years ago on Sunday September 23, 2012 | Permalink
  2. David Peralty
    Administrator

    Is there any place you can upload a screenshot of your notification settings so we can confirm they are the way you'd want? Also, are you receiving any notifications? Looking forward to helping you sort this out.

    Posted 7 years ago on Sunday September 23, 2012 | Permalink
  3. Luke
    Member

    Here is the link to the screenshot.
    http://birchpress.com/wp-content/uploads/2012/09/gravity.png

    I can receive notifications. But the from field of received emails is always my admin email which is support@birchpress.com though I set this field on the notification settings page with contactus@birchpress.com.

    BTW, I use the WP-Mail-SMTP plugin to set up my smtp server. The following is the link to the screenshot of email settings.
    http://birchpress.com/wp-content/uploads/2012/09/smtp-settings.png

    Posted 7 years ago on Monday September 24, 2012 | Permalink
  4. spiketv
    Member

    I am having this same issue... the notification from page is not being used in the email sent out.

    Posted 7 years ago on Monday September 24, 2012 | Permalink
  5. David Peralty
    Administrator

    Hwa - Your issue is that the WP SMTP plugin overrides everything before sending the e-mail, and that's why it always shows up as the e-mail address set in that plugin.

    Posted 7 years ago on Monday September 24, 2012 | Permalink
  6. Luke
    Member

    I use the following script to set up my smtp server. The result is that the send from field is always same with the smtp login user name. I guess gravityforms doesn't set the send from field.

    add_action('phpmailer_init','smtp_phpmailer_init');
    function smtp_phpmailer_init($phpmailer) {
    
        $smtp_options = get_option('smtp_options');
    
        // Set Mailer value
        $phpmailer->Mailer = 'smtp';
    
        // Set SMTPSecure value
        $phpmailer->SMTPSecure = $smtp_options['smtp_secure'];
    
        // Set Host value
        $phpmailer->Host = $smtp_options['host'];
    
        // Set Port value
        $phpmailer->Port = $smtp_options['port'];
    
        // If usrname option is not blank we have to use authentication
        if ($smtp_options['username'] != '') {
            $phpmailer->SMTPAuth = true;
            $phpmailer->Username = $smtp_options['username'];
            $phpmailer->Password = decrypt_string( $smtp_options['password'], CRYPT_KEY );
        }
    }
    Posted 7 years ago on Tuesday September 25, 2012 | Permalink
  7. Luke
    Member

    David, could you help me figure this out?

    Posted 7 years ago on Sunday September 30, 2012 | Permalink