PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Slow form submit

  1. We are experiencing slow form submit at a customers site, the wp_rg_lead_detail table has about 20000 records. Should it be slow with this amount of data, or is there things I should look out for that could cause it to be slow?

    How often do you recommend purging the database, and how do you recommend doing it? Can I just empty some of the Gravity form tables? Would have been nice to be able to purge the database form the admin interface.

    Posted 10 years ago on Wednesday May 30, 2012 | Permalink
  2. David Peralty

    Do you run any caching plugins? Do you generally do any database optimization? Does your site get a lot of traffic?

    These things might have more to do with performance than the number of leads in your table.

    The only thing I can think of is that you are checking for some unique entries (no duplicates)? If so, then maybe checking might take an extra little bit of time, but it shouldn't be slowing down too much, even with 20,000 records.

    What I would recommend would be to duplicate your form, and use it live without purging any data. This will mean that new submissions won't be tested against your no duplicates test if you have one. See if that has any increase in performance.

    Look for tutorials on optimizing a MySQL database, see if your host has any logs related to SQL that could be related to slowing things down. You should be able to have 100x that number of records without seeing much of a performance hit though.

    Posted 10 years ago on Wednesday May 30, 2012 | Permalink
  3. Thank you for your input David, were is the setting for duplicates, I could not find it when I was looking for it now.

    Posted 10 years ago on Wednesday May 30, 2012 | Permalink
  4. David Peralty

    Duplicate checks are done on a per-field basis. So you or whomever created the form would have set it if they wanted to check against it. Some people make it so that there can be no duplicate e-mail address submitted and so in the e-mail address field they would set it to be required and then also to be no duplicates. If you haven't set any "no duplicate" checking, then the form submission should go fine and it might be an issue with memory or the server.

    Do you have more than one form? If so, is this the only form with a slow submit?

    Posted 10 years ago on Wednesday May 30, 2012 | Permalink