PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

SMTP overwrites "From Email" field in Notficiations

  1. wilflare
    Member

    Hi all,
    I am using Google Apps for my Email
    Hostgator for my webhost
    GoDaddy for my domain and dns
    I have installed the SMTP plugin and it works fine

    HOWEVER,
    despite setting the From Email in both User and Admin Notification,
    I get notifications from the email I used in SMTP authentication

    Is there any setting I need to tweak to make the emails come from the setting I made in the "From Email" field?

    Posted 6 years ago on Thursday February 23, 2012 | Permalink
  2. Richard Vav
    Administrator

    I don't believe there is anything you can do to prevent this from happening, it is the way google's smtp servers operate, it always overwrites the from address with that of the account you are using for the smtp authentication.

    Posted 6 years ago on Thursday February 23, 2012 | Permalink
  3. wilflare
    Member

    ah :/ i thought i found the solution to remove that nasty "via"..
    oh well. there isn't any setting we can tweak?

    Posted 6 years ago on Thursday February 23, 2012 | Permalink
  4. Richard Vav
    Administrator

    The solution for the 'via' issue is to setup and enable spf and dkim in both your google apps admin panel and your domains dns records. But I am not aware of a way to prevent google's smtp servers replacing the from address with that of the account you are using for the smtp authentication in the wordpres smtp plugin.

    Posted 6 years ago on Thursday February 23, 2012 | Permalink
  5. wilflare
    Member

    for some strange reason.. the via is now reflecting my domain instead of the generic hostgator domain

    Posted 6 years ago on Friday February 24, 2012 | Permalink
  6. Richard Vav
    Administrator

    If you are using google smtp servers and authenticating using your google apps domain account then the via will display your domain rather than the generic hostgator domain, that is expected behaviour.

    Did you configure spf and DKIM?

    Have you seen the google support page for the via info http://support.google.com/mail/bin/answer.py?hl=en&ctx=mail&answer=1311182

    Posted 6 years ago on Friday February 24, 2012 | Permalink
  7. wilflare
    Member

    my situation is rather.. "complex"
    i am using GoDaddy as my Registrar (with my DNS config still there) -all the SPF and DKIM were done there..
    HostGator is my webhost (the CSO helped me setup my MX records there)
    wondering if what the CSO did resulted in the change to the via to my domain

    Posted 6 years ago on Friday February 24, 2012 | Permalink
  8. wilflare
    Member

    oh.. when i activated the SMTP plugin and punched in the settings.. all the via were (myusername@mydomain.org)

    after i deactivated the plugin, it's now via mydomain.org

    Posted 6 years ago on Friday February 24, 2012 | Permalink