PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Specific form won't save

  1. OMJS
    Member

    For some reason one of the forms is not saving anymore. So we can't edit it. Earlier it worked just fine. If we create a new form, we can edit and save. But this specific form won't anymore (earlier it did).

    The form is a temporary solution for a webshop of a customer that is down at the moment. So it has dropdowns with a lot of products. But I guess this is not the problem, because earlier it saved just fine.

    NOTE: We updated to the last version of GF, but it did not help.

    PS: GF is great! We use it for a lot of our websites. Have not found any other WP plugin for forms that is so versatile and jet so simple.

    Posted 7 years ago on Tuesday October 9, 2012 | Permalink
  2. Do you have the latest WordPress and Gravity Forms? If so, can you try another browser to ensure there is no cached JavaScript which might cause the form builder to stop working?

    Posted 7 years ago on Wednesday October 10, 2012 | Permalink
  3. OMJS
    Member

    We have the latest version of WP as well as GF. In different browsers the same problem occurs.

    Posted 7 years ago on Sunday October 14, 2012 | Permalink
  4. I have exactly the same problem. I create the form and add fields, but it will not allow me to save the form and when i navigate away from the page it looses all the work. PLEASE HELP!

    Posted 7 years ago on Thursday November 29, 2012 | Permalink
  5. If you are unable to save the form, it is normally one of a couple different things.

    Plugin or theme conflict: please troubleshoot by following these instructions http://rkt.gs/testing

    Out of memory: Please see how much memory PHP and WordPress have allocated on your server.

    Security restrictions: check with your host for any logging which might point to a problem

    Please start with these steps and let us know what your results are.

    Posted 7 years ago on Thursday November 29, 2012 | Permalink
  6. This happened to me when I had created conditional logic to show the form submit button, but subsequently deleted the item that was being used for the logic.

    Posted 7 years ago on Friday November 30, 2012 | Permalink
  7. Sounds like you figured out your problem, takes12no1?

    Posted 7 years ago on Saturday December 1, 2012 | Permalink
  8. Yes I did, I posted this for others to reference and so support could add to their list of solutions.

    I also think it could be considered a bug. The script should include a check for such things and throw a useful error instead of not saving. Or even better, turn off form conditional logic that points to an item that has been deleted or changed.

    BTW love your product!

    Posted 7 years ago on Saturday December 1, 2012 | Permalink
  9. Those are good suggestions. It's a gotcha that has gotten many people with complex conditional logic. I'll tag it as a feature request and see if we get more interest in it.

    Posted 7 years ago on Sunday December 2, 2012 | Permalink