PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Still getting an "Allowed memory size" error

  1. I have reviewed the forum posts where the same error has been reported, but none of the situations, and none of the solutions apply. The error:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/username/public_html/wp-content/plugins/gravityforms/form_detail.php on line 2177

    Unlike others posting this problem, the error in my situation did not happen during installation, etc. It happened when I tried adding a form. I tried this several times.

    I upped the memory_limit to 256M, tried deactivating other plugins, and updated the GF plugin using the auto-update. None of these possible solutions is working. I can use everything else in WordPress (only since updating GF), I can access GF Settings, etc, but I cannot get to Forms > New Form. When I try to add a form, I get the "Allowed memory size" error.

    WordPress 3.3.1
    GF Version 1.6.3.1
    PHP 5.2.17
    MySQL version 5.0.92-community-log
    Apache version 2.2.21
    OS Linux
    Memory limit (256M, verified with phpinfo.php)

    Posted 10 years ago on Saturday February 25, 2012 | Permalink
  2. Same error as above, only now it is happening when I login to WP again after logging out yesterday. Once I am logged in, I can't go anywhere from the Dashboard without getting the message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/poten625/public_html/wp-admin/admin-header.php on line 124

    The file name depends on what I try to do, but I get the "Allowed memory size" error all over the WP Admin. Once I deleted the plugin, everything worked again.

    In wp-config.php and in my php.ini the memory is set to 256M. Again, the 256 is confirmed when I run phpinfo.php.

    This is more than annoying especially since all over this forum the "solution" is to raise the memory limit. And this is a PAID plugin.

    Posted 10 years ago on Sunday February 26, 2012 | Permalink
  3. Does ANYONE from the GF development/support team read this forum?????

    The plugin is unusable due to the memory error and lack of a real solution for same.

    Posted 10 years ago on Wednesday February 29, 2012 | Permalink
  4. Hey - sorry about that, can you email me a login to rob@rocketgenius.com so I can take a look around?

    Posted 10 years ago on Thursday March 1, 2012 | Permalink
  5. As Rob mentioned above, send him the URL of the site, a WordPress admin login as well as an FTP login and he can look into this issue for you and debug it to determine exactly what is going on.

    That error IS a PHP Memory error. It is not a Gravity Forms error. So this is indeed some sort of memory issue. One issue could be the total amount of memory isn't actually being allocated properly because of web server or WordPress configuration settings. However, 256 MB is typically more than enough memory. Although We'll take a look and see what is going on.

    This is more than annoying especially since all over this forum the "solution" is to raise the memory limit. And this is a PAID plugin.

    This issue and the solution has nothing to do with the quality of Gravity Forms or the fact that it is a paid plugin. PHP memory settings on your host are completely out of our control AND overall memory usage is out of our control. Memory usage is impacted by your site as a whole, including the theme you are using and all of the plugins you are collectively running.

    Unfortunately many web hosts default to a very low amount of memory, 16 MB and 32 MB is very common for many shared hosts. This doesn't mean they limit you to this amount, but it does mean that this is the default and a lot of users run into memory issues because of this.

    This issue was originally posted over the weekend. We list in our support guidelines that we try and response to all NON-PRIORITY SUPPORT support forum posts in 48 hours. HOWEVER when an issue is posted over the weekend, it can sometimes take longer as our office is closed on the weekends.

    So with that in mind, I would appreciate it if you don't point fingers and instead allow Rob to assist you in determine what is going on. Our support team is here to help you and you will receive much better support if you interact with our support team in a positive rather than combative manner.

    Posted 10 years ago on Thursday March 1, 2012 | Permalink
  6. Theorian82
    Member

    I just had the same issue and fixed it using the suggested solutions. Mind you I'm managing my own VPS and so have access to php.ini configuration settings through WHM. If you don't have access to this (shared hosting environment etc.), like Carl said, you need to contact your hosting provider and have them deal with this issue as it can be fixed server side once you change your
    Wordpress mem limit. ** If in a shared environment, just remember that you're sharing the resources allocated with numerous other users - which is most likely going to be your problem ** and so you might need to look into a different hosting solution if still hitting the same issues post mem changes:

    Try this:
    1, Tell wordpress that it should be using more than 32M of PHP memory - in wp-config.php add the line: define('WP_MEMORY_LIMIT', '64M');

    Wordpress automatically allocates up to 32M of memory, this is why you need to set this limit higher than 32 in wp-config. You could even try testing 96M if still getting the error.

    2, Make sure that php.ini (server side) has it's memory limit set == your wordpress mem limit or higher. Depending on how much traffic your site receives or how many websites you're running, this limit may need to be set much higher than your wordpress limit. Again, if in a shared hosted environment, contact your host provider and ask them to do this.

    If using WHM, this can be done by going to Main >> Service Configuration >> PHP Configuration Editor.

    Hopefully this helps - and remember not to just increase your mem limit to a ridiculously high setting. They're relatively low for a reason, so don't increase it just for the sake of 'being safe'

    Posted 10 years ago on Saturday March 3, 2012 | Permalink