PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Submissions going through, but all entries are missing

  1. I just updated to the latest GF plugin yesterday. I am using GF + PayPal and User Registration plugins. Previously, I had no issues with the plugins.

    Today I have received numerous PayPal notifications and new users are added to the site. However, the Entries page is blank. No entries are recorded under that specific form (yes, I'm looking at the correct form).

    What could be causing the entries to not be recorded? I do not have Akismet activated and all my previous plugins did not cause any problems.

    Any ideas?

    Kristina

    Posted 10 years ago on Monday November 21, 2011 | Permalink
  2. I switched by to the previous versions of all 3 plugins and all the entries appeared. Looks like it's a glitch in the new versions.

    Posted 10 years ago on Monday November 21, 2011 | Permalink
  3. It's not a glitch. It sounds like either 1) a PHP memory issue or 2) a plugin conflict. My guess is it's a PHP memory issue. Your site is most likely running out of available PHP memory so when it goes to show the entries page, it runs out of memory before it completes the process.

    You need to increase your available PHP memory. Here is a tutorial on how to do this:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    You may need to discuss this with your web host.

    Posted 10 years ago on Monday November 21, 2011 | Permalink
  4. If that's the case, why would a simple downgrade to previous versions of the plugins seem to solve the issue? All of the missing entries appeared the minute after I downgraded? I'm really confused. Are you saying that the new versions require more PHP memory?

    Posted 10 years ago on Monday November 21, 2011 | Permalink
  5. Why? Because the older version probably utilized less memory because it had less features and options. There is more code involved in the new version, so yes it could impact PHP memory depending on what your servers PHP memory settings are.

    WordPress itself changes from release to release how much memory it needs. Then themes and plugins do the same. Based on your description, it sounds like you are hitting a wall and when you install the new version... you hit your limit.

    PHP memory is typically easy to increase. Most (good) hosts allow you to do so. They typically default to a low amount and then you can raise it from there. It's typically not something you pay for, it's simply a server setting.

    Posted 10 years ago on Monday November 21, 2011 | Permalink
  6. treuter
    Member

    We're experiencing this on our site as well. The entries are, in fact, in the MySQL database, but not displaying in the WordPress > Forms > Entries UI. Can RocketGenius identify a recommended amount of PHP memory to allocate and publish it as a requirement?

    Dan

    Posted 10 years ago on Wednesday November 30, 2011 | Permalink
  7. @treuter It's really going to depend on a number of factors. I would say a minimum of 64 MB and ideally 128 MB or more. If this is a memory issue. What you describe does sound like a memory issue, but it could be something more obscure. I would suggest starting with increasing the memory and then if that does not correct the issue we can dig deeper.

    Posted 10 years ago on Wednesday November 30, 2011 | Permalink
  8. treuter
    Member

    We've increased the memory in WordPress to 128MB and the limit in PHP to 256MB. The entries still aren't displaying in the WordPress > Forms > Entries UI.

    We do have a dev and prod version of our site. The entries are displaying fine on the dev server, but not on the production one. Both sites have the same plugins and version of WordPress.

    Posted 10 years ago on Thursday December 1, 2011 | Permalink
  9. Hello Dan,
    What I would recommend is turning debugging ON, by setting WP_DEBUG to TRUE in the wp-config.php file. Then go to the entries page and see if any errors show up. That might give us some clues as to why entries aren't being displayed.

    Posted 10 years ago on Thursday December 1, 2011 | Permalink
  10. treuter
    Member

    We quickly turned on Debug mode and I received the following message:

    Notice: Undefined index: aiosp_enabled in /var/www/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 766 Notice: Undefined index: aiosp_enabled in /var/www/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 766 Notice: Constant FORCE_SSL_ADMIN already defined in /var/www/wp-config.php on line 93 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/wp-includes/functions.php on line 3466 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /var/www/wp-includes/functions.php on line 3466 Notice: Trying to get property of non-object in /var/www/wp-includes/post-template.php on line 30 Notice: Trying to get property of non-object in /var/www/wp-includes/post-template.php on line 30

    Posted 10 years ago on Wednesday December 7, 2011 | Permalink
  11. Hello Dan,
    I don't think those notices are the source of our problem here. I will be glad to take a closer look, but I will need a WP admin and FTP login. If you can send them to alex@rocketgenius.com I will try to see what is going wrong.

    Posted 10 years ago on Wednesday December 7, 2011 | Permalink
  12. treuter
    Member

    @Alex

    Unfortunately, sending you WP credentials isn't really an option. Do you have any other suggestions that I can explore on our end?

    Thanks

    Posted 10 years ago on Wednesday December 7, 2011 | Permalink
  13. treuter
    Member

    I'd like to try to roll back to version 1.6 of Gravity Forms. Can you supply a link to that version so we can see if that corrects the issue?

    Thanks

    Posted 10 years ago on Monday December 12, 2011 | Permalink