PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Submit button not working in IE

  1. Using IE version 9.

    Link to form: http://freelanceexpress.co.za/freelance-express-get-a-quote/

    The submit button works fine in Firefox, Chrome but in IE it does nothing when you click on it.

    What could be the problem?

    Posted 8 years ago on Wednesday November 21, 2012 | Permalink
  2. The first thing to do would be to validate the HTML on the page:
    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Ffreelanceexpress.co.za%2Ffreelance-express-get-a-quote%2F

    There are a bunch of errors. Every browser responds differently to invalid HTML and it's possible Chrome and Firefox are overlooking the error, but IE9 is choking on it. Please take a look at these errors. I see a few unclosed form and div elements and I suspect one of those is causing the problem with the form in IE.

    Posted 8 years ago on Wednesday November 21, 2012 | Permalink
  3. I'm having the same issue in Chrome - safari seems to be fine.

    I have 22 errors but they all seem to be in the GF markup - http://validator.w3.org/check?uri=http%3A%2F%2Ffrancisbond.com%2Fmelbourne%2Fweb-designer%2Fweb-site-briefing-form%2F&charset=%28detect+automatically%29&doctype=Inline&group=0&verbose=1&user-agent=W3C_Validator%2F1.3#preparse_warnings

    Posted 8 years ago on Wednesday November 28, 2012 | Permalink
  4. I received a 404 error for that URL when I pulled it from the w3c validator page.

    Posted 8 years ago on Saturday December 1, 2012 | Permalink
  5. Hey Chris,

    The form had since moved - sorry.

    http://validator.w3.org/check?uri=http://francisbond.com/services/web-designer/web-site-briefing-form/

    Posted 8 years ago on Saturday December 1, 2012 | Permalink
  6. I would disable W3 Total Cache or at least turn off the script minification. If that does not help, I would begin troubleshooting by checking for theme and plugin conflicts, using these instructions http://rkt.gs/testing

    Thank you.

    Posted 8 years ago on Saturday December 1, 2012 | Permalink
  7. Thanks Chris - I'll start there.

    Mat

    Posted 8 years ago on Saturday December 1, 2012 | Permalink
  8. Let us know what you find out.

    Posted 8 years ago on Saturday December 1, 2012 | Permalink
  9. OK,

    So I did as you suggested.

    1. I disabled minify setting in Total cache - no change
    2. I disabled Total Cache - no change
    3. I disabled could flare & my CDN - no change
    4. I set permalinks to default - no change
    5. I changed the theme to Twenty Eleven - no change
    6. I disabled ALL plugins except Gravity Forms - no change

    So it must be something to do with the form itself.

    You can download my export fo the form here - https://dl.dropbox.com/u/10253663/posted%20images/gravityforms-export-2012-12-02.xml.zip

    Posted 8 years ago on Sunday December 2, 2012 | Permalink