PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Submit not happening

  1. Sigh, something isn't working.

    I created a form that is a questionnaire. The person who submits it gets a long email with the results. I had it working, but not the Mail Chimp connection. ( I sent a different request about that) I took out Captcha because I thought it was ugly. Now when I attempt to fill out the form, it doesn't submit at all. No notifications. Help?

    Posted 11 years ago on Wednesday May 4, 2011 | Permalink
  2. Hi Annamarie,

    It doesn't appear that the Gravity Form scripts are being output correctly. Are you adding this form via a shortcode in the post content? If so, could you try loading another form via shortcode and seeing if this issue exists for that as well?

    Posted 11 years ago on Wednesday May 4, 2011 | Permalink
  3. Ah ha! You're on to something.

    I couldn't automatically generate a shortform code for this form. That's the first problem and probably where the problem is. I created one manually following directions.

    My other form (found on the Contact page) was made before upgrading to the latest 1.5.2. It too won't make me a shortcode to put into a post. Does this help trace it?

    Posted 11 years ago on Wednesday May 4, 2011 | Permalink
  4. In order to look into your issues we would need a WordPress admin login for your site. You can send this information to us via our Contact Us form and provide detailed information on what problem(s) you are having and we will look into it.

    Posted 11 years ago on Thursday May 5, 2011 | Permalink
  5. I have given you an admin login - sent it via the contact us form this morning.
    This is the page i'm having trouble with:

    Posted 11 years ago on Friday May 6, 2011 | Permalink
  6. Something on your site isn't loading AJAX correctly. The solution to this is to turn off AJAX in the shortcode. AJAX isn't necessary for forms to work and it isn't necessary for most forms. There are certain situations where AJAX is used, it generally does not need to be used. I disabled AJAX on the shortcode for your form and it is working fine now and submitting and saving information exactly as it should be.

    As for your issue "Making a shortcode" this is a browser cache issue. You need to completely clear your browser cache and then try again. I have no problems using the "Insert shortcode wizard" to insert form shortcodes on pages or posts on your site. When this isn't working it's due to browser cache not loading the necessary scripts because it loads from cache.

    Posted 11 years ago on Friday May 6, 2011 | Permalink