PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Theme + IE8 conflict

  1. cbg
    Member

    Hey Guys,

    Working on this site currently: http://stg2.clearbridge.com.au/

    Anyway, when I use the shortcode to add a gravity form to a page, it breaks the theme and doesn't display the cufon properly. This issue only exists in IE8. I am using this page as a test page: http://stg2.clearbridge.com.au/test-page

    It works fine in Firefox, IE9, Chrome and Safari. It's only IE8 that has the issue. I know it's only one browser but IE8 accounts for over 30% of all traffic to my website, so I have to look after those users!

    Just wondering if anyone has any advice/feedback as to what I can do.

    Thanks

    Posted 8 years ago on Saturday July 9, 2011 | Permalink
  2. cbg
    Member

    Anyone? Please.

    Posted 8 years ago on Monday July 11, 2011 | Permalink
  3. I've been looking at it and I'm guessing it's a script conflict of some sort. You're loading lots of scripts on that page and IE is timing out and not loading all the supporting page CSS, etc. I doubt this has anything directly to do with GF since the plugin normally works fine in IE8 but I haven't been able to find anything specific yet. You might want to try toggling off some of those scripts and or plugins to see if that makes any difference.

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 8 years ago on Monday July 11, 2011 | Permalink
  4. cbg
    Member

    Thank you. Will give it a crack and report back.

    Posted 8 years ago on Monday July 11, 2011 | Permalink
  5. Okay, I dug around a little more and found this. The PIE.js file is throwing an error in IE8

    screenshot: http://bit.ly/pZXydx

    but not in IE9

    screenshot: http://bit.ly/oS2VT7

    I can't tell you what it is about that script that's making it angry, but that appears to be the source of your issue.

    Posted 8 years ago on Tuesday July 12, 2011 | Permalink