PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

This Page is unsecured

  1. tracklab
    Member

    Hi,
    I first signed up to Personal then switched to developer as i needed the paypal integration as it would really help with my new site.

    i am getting this error msg in red: This page is unsecured. Do not enter a real credit card number. Use this field only for testing purposes.

    screenshot link: http://awesomescreenshot.com/0a89nufce

    I'm new to wordpress and not sure what i am doing wrong and i have looked through the forum but a little confused with it..

    can someone please assist?

    thank you

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  2. David Peralty
    Administrator

    You need a SSL if you want to have that message goes away. Basically it is warning people that the form isn't secured and if you put in your details, they won't be encrypted before sending and someone could intercept them.

    SSL certificates negate this problem. Talk to your web host if you want more details on SSL certificates, why you need them and how much they cost.

    Hope this helps.

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  3. tracklab
    Member

    ok..
    it seems that this came up because i had authorise activated and i didn't need it..
    all i wanted was paypal standard add-on, which worked ..

    but my question now will be i am creating another form in another section of my website which i would need another paypal option, it seems to only be working on one form and not the other..

    i.e. the total is not adding up on my second form which is not taking things to paypal?

    screen shot:
    http://awesomescreenshot.com/01d9o3ff6

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  4. tracklab
    Member

    so in my case, i have a online services form to book studio mixing service and i need another form for studio booking and would like both to have the option for the client to either pay a deposit or pay in full..
    the online services form seems to be working and taking me to paypal page for payment.. whereas the studio booking is not, and i have noticed that in form edit > preview the total amount is not populating [hope that makes sense]

    i did also go into paypal options>add new form and entered my paypal email as required.. still nothing..

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  5. David Peralty
    Administrator

    Can you embed the form and link to it so I can take a look at what is going on?

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  6. tracklab
    Member

    screen shot of item chosen online but no total showing:
    http://awesomescreenshot.com/09d9o4z92

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  7. tracklab
    Member

    this is the form preview is this what you are asking? : http://tracklabstudios.com/?gf_page=preview&id=5

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  8. David Peralty
    Administrator

    Not the preview URL because I would have to be logged in for that. A live page that I can look at things for you.

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  9. tracklab
    Member

    live website? sorry I'm so new to this and i appreciate your time and efforts..
    http://tracklabstudios.com/?page_id=1201

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  10. tracklab
    Member

    http://tracklabstudios.com/?page_id=1201

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  11. David Peralty
    Administrator

    Can you send admin login details to peralty@rocketgenius.com. I don't think you have your product fields set-up correctly, which is why the total isn't working.

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  12. tracklab
    Member

    sending now..

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  13. David Peralty
    Administrator

    If you log in, you can see I duplicated your form. I am going to send a bug report to the developers, but here's what I did to get it working. I made the product basically nothing, and then added an option field where I put in the various options you had. That way, the product is studio booking and the options are related to that.

    It updates the price as it should. Feel free to test it out.

    The other way of doing it would be to make four separate products, rather than one product with four prices, as for some reason that wasn't working.

    Feel free to apply my changes to your main form, or try the multiple product route. All my best!

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  14. tracklab
    Member

    Hey David,

    Oh so thats a bug... cool, hope it gets ironed out :-)
    ok thank you, ill see how this goes..
    if i need another form ill try do the same if this issue arises again..

    can we be notified if/when this bug is fixed at all please?
    id appreciate it..

    thanks again for your time David

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  15. David Peralty
    Administrator

    We don't inform anyone individually, but we do post changes on our development blog which you can subscribe to.

    http://feedburner.google.com/fb/a/mailverify?uri=gravityhelp/WvJm&loc=en_US

    Posted 7 years ago on Wednesday July 4, 2012 | Permalink
  16. Apparently, we can avoid this message by using Paypal rm parameter.
    No SSL seems mandatory to avoid this message.
    Woocommerce has just fixed this issue recentely like that.
    David : could you please ask devs to test this solution ?

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  17. I have just tested to replace rm parameter setting and it seems to be working good now : no more nagging message.
    The devs should now see if it's OK with the rest of the program.

    The rm parameter should be set to 2 only when using SSL. If not, set it to 1.

    Here is the (basic) modification since don't use SSL at all for now :

    Edit gravityformspaypal/paypal.php near line 1753 :

    $return_url = "&return=" . urlencode(self::return_url($form["id"], $entry["id"])) . "&rm=1";

    Regards,
    Antoine

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  18. frogtownmedia
    Member

    Thanks mediana! Changing the rm variable to 1 worked great. Hopefully a future release will include that as an option in the PayPal settings. Until then we'll just have to remember to reapply that change after upgrades.

    Posted 7 years ago on Monday August 27, 2012 | Permalink
  19. I've brought this to the attention of the developers again. Thank you.

    Posted 7 years ago on Sunday October 14, 2012 | Permalink
  20. The rm PayPal parameter is used to control how the page is sent back from PayPal to your site. With rm=1, PayPal will simply redirect the user to your site, and rm=2 will actually post the data back to the site. We have decided to use rm=2 as that could be useful for some users that need to display that information on their pages. I am not sure why the warning message is being displayed, but that is something specific to some configurations, and not to everybody. We will look for a way to allow the rm parameter to be changed via a hook and also try to find out why the return URL is not using HTTPS for some users.

    Posted 7 years ago on Tuesday October 16, 2012 | Permalink

This topic has been resolved and has been closed to new replies.