PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

time delay after submitting form

  1. My form seems to delay enough where my visitors are clicking multiple times on the button. Not sure if its a server issue, or other programming issue. Could having a lot of submissions in the database slow the time processing down? I have the Zoho addon (3rd party app) don't know if that's doing it?

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  2. David Peralty

    There are so many potential factors that it is usually hard to narrow it down. What I usually suggest is to make one field a unique entries only, then they can't submit multiple times. Or find a JS call that can disable the submit button after the first press. Either way, it is easier than hunting down the delay.

    If you want to hunt down the delay, and are experiencing it yourself, I would suggest looking through our theme and plugin conflict instructions first:
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    And maybe contacting your host for log details or to see if they can bump up the available memory for PHP.

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  3. David,

    Could you please explain "make one field a unique entries only?" I have required fields but I don't think that is what you mean.

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  4. David Peralty

    Right next to the required checkbox is No Duplicates. Check that off for a single field and they won't be able to submit the same entry multiple times.

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  5. The problem with that is if they click it a 2nd time then the "no duplicates message comes up" so even though it was unique on the first click now it's not unique anymore and the 2nd form doesn't show up so the visitor is confused.

    I guess your other suggestion: Or find a JS call that can disable the submit button after the first press
    is the way to go? Is that very complicated to do being not a programmer. I'll have to hire my guy again.

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  6. David Peralty

    Here is something someone wrote:
    http://www.mkyong.com/jquery/how-to-disable-submit-button-after-clicked-with-jquery/

    Here is information on where the code would go:
    http://www.gravityhelp.com/documentation/page/Where_Do_I_Put_This_Code%3F

    Posted 9 years ago on Thursday July 19, 2012 | Permalink
  7. Or, Rob has posted one possible solution to do that here as well:
    http://www.gravityhelp.com/forums/topic/is-it-possible-to-hide-the-submit-button-after-it-has-been-clicked#post-41113

    Posted 9 years ago on Friday July 20, 2012 | Permalink