PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Total Field not updating on one site, does on the other

  1. I have a form that is working great on this page:

    http://sitesinoneday.com/submit-payment/

    However the totals field is not updating correctly on this page:

    http://pacgr.com/make-a-contribution/

    I even tried exporting the form from sitesinoneday.com and imported it into pacgr.com and the total field does not update on pacgr.com. The Gravity Forms settings are identical on both pages. And I tried disabling all but the Gravity Forms and Gravity Form PayPal plugins and it didn't work. Both sites are on the same server account at HostGator.

    What am I missing? Frustrated this moring.

    Thanks in advance for the help!

    --Perry

    Posted 7 years ago on Saturday December 1, 2012 | Permalink
  2. The site which works i using jQuery version 1.7.2 which is supplied by WordPress. That's the jQuery that Gravity Forms relies on.

    The site which does not work is using jQuery version 1.8.3 from googleapis.

    <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js?ver=3.4.2'></script>

    I believe that's the source of the problem. If you can, switch the jQuery version being used on the broken site to the included version 1.7.2 enqueued by WordPress and I think you will see that the total field works.

    Posted 7 years ago on Sunday December 2, 2012 | Permalink
  3. Thanks Chris, but where do I edit it. Which file is it located in.

    Thanks
    --Perry

    Posted 7 years ago on Sunday December 2, 2012 | Permalink
  4. That is provided by a theme or plugin, not by WordPress core and not by Gravity Forms. You will need to check your theme and plugins for where that code is added. Any plugin which uses jQuery might include its own version, or the theme itself could do it.

    You could use the plugin and theme troubleshooting procedures to find out where the jQuery is coming from. http://rkt.gs/testing . Just deactivate the theme or a plugin, refresh the page, then check the source for the additional jQuery version.

    Posted 7 years ago on Sunday December 2, 2012 | Permalink
  5. It is the theme. I switched to the twenty ten theme and it functions fine. Is there a way to have the theme use one version and gravity forms use another?

    Thanks again for your help. And thanks for the tip on trouble shooting. Never thought to blame the theme for breaking how the form functions. I should have thought of it when I disabled all the plugins but the gravity forms and it still didn't work. The only difference was the theme at that point, between the site that worked and the one that did not.

    Thanks again.

    --Perry

    Posted 7 years ago on Sunday December 2, 2012 | Permalink
  6. Glad you found the problem.

    To use two versions of jQuery at the same time, see this:
    http://stackoverflow.com/q/1566595

    I've never seen a need for it, but it's possible you have functionality on the page which requires the latest version. Have you tried using just 1.7.2?

    Posted 7 years ago on Monday December 3, 2012 | Permalink