PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

trailing /? added to confirmation redirect

  1. I've got a problem with the confirmation redirect adding a /? to the end of the designated page.
    Example:
    When you fill out the first form on this page:
    http://www.adhdcoaches.org/acce-kubik/
    the professional registration redirects to
    http://www.adhdcoaches.org/po-kubik-m/?

    Sometimes *I* get the page as it should be, other times my experience matches the complaints from users saying that they get a blank where the post/content should be.

    Using Firefox Live HTTP Header add on, the header shows
    XML-RPC server accepts POST requests only.
    (I don't really know what that means)(S)

    Some things I've read seem to imply that this could be a problem with the cache. But no specific cache plugin is installed. Some conversations I've had with my guys suggest a problem with the Apache handler.

    I have done the "switch to the twenty ten" theme... same problem.
    and the turn off all the other plugins... same problem
    I tried making a new form with the same redirect confirmation, same problem.

    I tried changing the permalink structure to test the problem as suggested here:
    http://www.gravityhelp.com/forums/topic/form-not-submitting#post-2233

    However, when I set the permalinks to default (which given the ? might imply that's where the problem is) they don't change. They stay as domain/post-name

    When I change it back.. I get the message that the .htaccess is not writeable .. I changed the chmod to 777 .. still not writeable.
    I manually changed the .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    // [the following line was not included before] (and no, this line is not in the actual file)
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    That's all I've got about that problem.
    However, here's some other stuff that happened:

    I had some trouble after the last WP upgrade adding weird characters. But I found that the DB_CHARSET did not match the set shown on the mysql database. I changed the DB_CHARSET to utf8_unicode_ci and that fixed the weird character problem.

    But is it possible there could be a problem with the DB_CHARSET?
    See my post about that here: http://bit.ly/mc6Ha9

    I'm at a loss for where to look next (or better to fix this problem!)
    Thanks
    kerch
    http://www.adhdcoaches.org

    Posted 9 years ago on Sunday July 3, 2011 | Permalink